Search Issue Tracker

Fixed in 2017.1.0f3

Fixed in 5.4, 5.5, 5.6

Votes

39

Found in

5.5.2f1

2017.2.0f3

Issue ID

888859

Regression

Yes

Android Build fails when the latest Android SDK Tools 25.3.1 version is used

Android

-

How to reproduce:
1. Update Android SDK Tools to 25.3.1
- In Mac open Android Studio -> Check for updates and update Android Studio version (might be not necessary)
- In Android Studio -> Preferences -> Appearance & Behavior -> System Settings -> Android SDK -> SDK Tools
2. Create a new Unity project
3. Build and run on Android device
Result: Build fails "CommandInvokationFailure: Unable to list target platforms. Please make sure the android sdk path is correct. See the Console for more details. ..."

Reproducible: 5.5.2p2, 5.6.0b11, 2017.1.0a3

Note: I haven't been able to reproduce this issue on Windows machine. As after update via Android Studio, SDK Manager still doesn't see SDK Tools 25.3.1 version and uses 25.2.5

Workaround for the customers.

1) just open https://developer.android.com/studio/index.html
2) scroll down to the bottom of that page
3) go to downloads
4) scroll down to the bottom of that page
5) find Windows "tools_r25.2.3-windows.zip" download and unzip it
5) find MacOSX "tools_r25.2.3-macosx.zip" download and unzip it.
6) In the SDK path replace the tools folder.

FIXED:
Unity versions: 5.4.5p2, 5.5.3p3, 5.6.0p3, 2017.1.0b3
SDK Tools have to be updated to 26.x.x

Comments (143)

  1. 2112a12b794b8e611be763530167de8d?d=mm

    tricalnikhil

    Jul 25, 2017 23:18

  2. 39937490f82baf10b8e3b0ae65688f61?d=mm

    yixiaoqingyuz

    Jul 23, 2017 17:05

    I found that you need to update your java to version1.8 to fix this bug!

  3. 61b16c51a83a4f3c4b3cfe013939fed6?d=mm

    ESG-Steven

    Jun 29, 2017 22:47

    Same Problem in 5.6.0f3 and having the same issue as Barney_Devrookie... Those downloads no longer exists. Android Studio only gives the most recent version of the sdk tools

  4. 6cfccaee8a927cf7f1a974c5ee88dff0?d=mm

    Ciaran

    Jun 28, 2017 21:42

    This still seems to be an issue. 5.6.2f1 on mac and Android tools 26.0.2 (installed by Android Studio)

  5. 83c9c990ed3c141dd6570eb29867d2fd?d=mm

    sethshort

    Jun 21, 2017 17:55

    This error appears for me. Using:

    Unity 5.6.1f1

    Java JDK 8u131

    Android SDK Tools 2.3.3, downloaded here per Unity's instructions: https://dl.google.com/android/repository/sdk-tools-windows-3859397.zip

    There is NO "Android.exe" as the instructions indicate there should be, so I downloaded Android Studio and used it to update my SDKs into my chosen folder, C:\android-sdk.

    Upon "Build and Run", I get the error:
    CommandInvokationFailure: Unable to list target platforms. Please make sure the android sdk path is correct. See the Console for more details.
    C:\Program Files\Java\jdk1.8.0_131\bin\java.exe -Xmx2048M -Dcom.android.sdkmanager.toolsdir="C:/android-sdk\tools" -Dfile.encoding=UTF8 -jar "C:\Program Files\Unity\Editor\Data\PlaybackEngines\AndroidPlayer/Tools\sdktools.jar" -

    stderr[
    Error:Invalid command android
    ]
    stdout[

    ]
    exit code: 64
    UnityEditor.Android.Command.Run (System.Diagnostics.ProcessStartInfo psi, UnityEditor.Android.WaitingForProcessToExit waitingForProcessToExit, System.String errorMsg)
    UnityEditor.Android.AndroidSDKTools.RunCommandInternal (System.String javaExe, System.String sdkToolsDir, System.String[] sdkToolCommand, Int32 memoryMB, System.String workingdir, UnityEditor.Android.WaitingForProcessToExit waitingForProcessToExit, System.String errorMsg)

  6. E77d33630cd12322ebce5e345385b5cb?d=mm

    gbkamwp

    Jun 18, 2017 23:00

    This is still a problem in 19.7.2017 , using Unity 5.6.0f3 Win10.

  7. 9eb7bceac788ac6a7621b4141f7fd367?d=mm

    WOOYU

    Jun 14, 2017 22:13

    I used to have this issue, and I had success after upgrading Android SDK, Unity, and then finally JDK.
    I didn't even have terribly old versions (all within 6 months), but upgrading them still to the latest versions solved the issue for me.

  8. 36f94c6bf3422c1451c3c8c39135f319?d=mm

    nask

    Jun 09, 2017 08:46

    I installed 5.6.1p2 - and the issue persists

  9. Fac6fe97371c222d1f5bc394289f9618?d=mm

    VickySmalley

    Jun 07, 2017 15:14

    I'm also finding that this is NOT fixed in 5.4.5p2 on mac, also getting the problem with merging manifests.

  10. 26cee5a0c17a97aac8e38e9da93c8ca3?d=mm

    MichiealO

    May 31, 2017 21:32

    @JGWINNER - Thank you for this... This morning, I screwed over my ability to make Android games courtesy of another post.
    @UnityTechnologies - For this issue supposedly being "Fixed" according to Unity Technologies, I sure do seem to have an issue with it not being able to build without getting the error that everyone else gets... And, in 5.6.1f, I would think that it would be fixed by now? I mean, this has been an issue since early versions of Unity 4!!!

    So, add all 10 of my votes to Unity Technologies ACTUALLY fixing this issue, rather than backburner-ing it again.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.