Search Issue Tracker

Fixed in 2017.1.0f3

Fixed in 5.4.X, 5.5.X, 5.6.X



Found in



Issue ID




Android Build fails when the latest Android SDK Tools 25.3.1 version is used



How to reproduce:
1. Update Android SDK Tools to 25.3.1
- In Mac open Android Studio -> Check for updates and update Android Studio version (might be not necessary)
- In Android Studio -> Preferences -> Appearance & Behavior -> System Settings -> Android SDK -> SDK Tools
2. Create a new Unity project
3. Build and run on Android device
Result: Build fails "CommandInvokationFailure: Unable to list target platforms. Please make sure the android sdk path is correct. See the Console for more details. ..."

Reproducible: 5.5.2p2, 5.6.0b11, 2017.1.0a3

Note: I haven't been able to reproduce this issue on Windows machine. As after update via Android Studio, SDK Manager still doesn't see SDK Tools 25.3.1 version and uses 25.2.5

Workaround for the customers.

1) just open
2) scroll down to the bottom of that page
3) go to downloads
4) scroll down to the bottom of that page
5) find Windows "" download and unzip it
5) find MacOSX "" download and unzip it.
6) In the SDK path replace the tools folder.

Unity versions: 5.4.5p2, 5.5.3p3, 5.6.0p3, 2017.1.0b3
SDK Tools have to be updated to 26.x.x

Comments (171)

  1. wassim-s-haddar

    Apr 22, 2017 18:54

    Thanks a lot that really helps out in Unity 5.6.0f3

  2. ethanwgross

    Apr 21, 2017 22:29

    @MRDUDE you rock dude. only working link for that file I could find anywhere.

  3. carocky

    Apr 21, 2017 11:59

    Thanks JGWinner for linking the old tools. I have just built a new PC and installed unity/android from scratch. Can't find the old tools anywhere - except from your link!

  4. Studiomaurer

    Apr 07, 2017 15:27

    For me the fix isn't woking, it seems to want 26.0.0 explicitly.

    * What went wrong:
    A problem occurred configuring root project 'gradleOut'.
    > failed to find Build Tools revision 26.0.0

    Hmm, what now?

  5. Studiomaurer

    Apr 03, 2017 09:37

    Hmm, tried this on Mac. However now the build fails because:

    * What went wrong:
    A problem occurred configuring root project 'gradleOut'.
    > failed to find Build Tools revision 26.0.0

    Bummer, seems I'm stuck now.

  6. Christian-Tucker

    Apr 02, 2017 10:38

    @JGWINNER I have applications that aren't in Unity that are dependent on the newer sdk-tools. Having to go back and forth is quite annoying. Shouldn't this just be resolved ASAP instead of causing a headache to the end user?

  7. Cmoche

    Mar 31, 2017 18:28

    Reproduced on Windows 10
    Unity 5.5.1f1 Personal
    Android Studio 2.3
    Android SDK Tools 25.2.5

    Confirming the above Fix Steps from JGWINNER dated March 09, 2017 work to correct the issue for the above listed version and build setup in Windows.

  8. MrDude

    Mar 21, 2017 15:23

    I notice it says "" at the end there. Does this imply that the files won't work in OSX? What is the fix for us Mac users?

  9. jr_mike

    Mar 16, 2017 22:34

    @JGWINNER : That fix does indeed work, thanks for providing that. Only problem is you can build an APK but you cannot 'Build and Run' to deploy to the device through Unity after doing that, since it doesn't seem to work with ADB correctly.

    I'm pretty sure this is some really, really old pre-gradle era Unity code that checks to see if ANT is available, but because it's removed from the Android SDK now, it assumes the SDK isn't installed.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.