Search Issue Tracker

Fixed in 2017.1.0f3

Fixed in 5.4.X, 5.5.X, 5.6.X



Found in



Issue ID




Android Build fails when the latest Android SDK Tools 25.3.1 version is used



How to reproduce:
1. Update Android SDK Tools to 25.3.1
- In Mac open Android Studio -> Check for updates and update Android Studio version (might be not necessary)
- In Android Studio -> Preferences -> Appearance & Behavior -> System Settings -> Android SDK -> SDK Tools
2. Create a new Unity project
3. Build and run on Android device
Result: Build fails "CommandInvokationFailure: Unable to list target platforms. Please make sure the android sdk path is correct. See the Console for more details. ..."

Reproducible: 5.5.2p2, 5.6.0b11, 2017.1.0a3

Note: I haven't been able to reproduce this issue on Windows machine. As after update via Android Studio, SDK Manager still doesn't see SDK Tools 25.3.1 version and uses 25.2.5

Workaround for the customers.

1) just open
2) scroll down to the bottom of that page
3) go to downloads
4) scroll down to the bottom of that page
5) find Windows "" download and unzip it
5) find MacOSX "" download and unzip it.
6) In the SDK path replace the tools folder.

Unity versions: 5.4.5p2, 5.5.3p3, 5.6.0p3, 2017.1.0b3
SDK Tools have to be updated to 26.x.x

Comments (165)

  1. 9b7b89328063f435938d45477c84e35e?d=mm


    Jul 31, 2017 08:34

    This problem is not closed! This issue is still happening: hardcodeddebug mode is still breaking the apk build.

    I have tried with a new clean project on Unity 2017.1.0f3 on MacOSX and Windows 10. There are no AndroidManifest files in the project but when one is generated, android:debuggable="false" is being inserted. This cannot be overridden with a custom AndroidManifest in /plugins/Android.

    I have tried including the tools xmlns and using tools:replace="android:debuggable" as well as tools:remove="android:debuggable" in the application tag of the androidmanifest but the debuggable="false" is STILL being inserted into the same tag and generating an error.

    Unity 2017.1.0f3, Gradle build, IL2CPP

    Could someone please take a look? The above fixes and tool versions are not working for me.

  2. 5b3d00862ae5c91d2b249a266a764aaf?d=mm


    Jul 28, 2017 07:36

  3. 2112a12b794b8e611be763530167de8d?d=mm


    Jul 25, 2017 23:18

  4. 39937490f82baf10b8e3b0ae65688f61?d=mm


    Jul 23, 2017 17:05

    I found that you need to update your java to version1.8 to fix this bug!

  5. 61b16c51a83a4f3c4b3cfe013939fed6?d=mm


    Jun 29, 2017 22:47

    Same Problem in 5.6.0f3 and having the same issue as Barney_Devrookie... Those downloads no longer exists. Android Studio only gives the most recent version of the sdk tools

  6. 6cfccaee8a927cf7f1a974c5ee88dff0?d=mm


    Jun 28, 2017 21:42

    This still seems to be an issue. 5.6.2f1 on mac and Android tools 26.0.2 (installed by Android Studio)

  7. 83c9c990ed3c141dd6570eb29867d2fd?d=mm


    Jun 21, 2017 17:55

    This error appears for me. Using:

    Unity 5.6.1f1

    Java JDK 8u131

    Android SDK Tools 2.3.3, downloaded here per Unity's instructions:

    There is NO "Android.exe" as the instructions indicate there should be, so I downloaded Android Studio and used it to update my SDKs into my chosen folder, C:\android-sdk.

    Upon "Build and Run", I get the error:
    CommandInvokationFailure: Unable to list target platforms. Please make sure the android sdk path is correct. See the Console for more details.
    C:\Program Files\Java\jdk1.8.0_131\bin\java.exe -Xmx2048M"C:/android-sdk\tools" -Dfile.encoding=UTF8 -jar "C:\Program Files\Unity\Editor\Data\PlaybackEngines\AndroidPlayer/Tools\sdktools.jar" -

    Error:Invalid command android

    exit code: 64
    UnityEditor.Android.Command.Run (System.Diagnostics.ProcessStartInfo psi, UnityEditor.Android.WaitingForProcessToExit waitingForProcessToExit, System.String errorMsg)
    UnityEditor.Android.AndroidSDKTools.RunCommandInternal (System.String javaExe, System.String sdkToolsDir, System.String[] sdkToolCommand, Int32 memoryMB, System.String workingdir, UnityEditor.Android.WaitingForProcessToExit waitingForProcessToExit, System.String errorMsg)

  8. E77d33630cd12322ebce5e345385b5cb?d=mm


    Jun 18, 2017 23:00

    This is still a problem in 19.7.2017 , using Unity 5.6.0f3 Win10.

  9. 9eb7bceac788ac6a7621b4141f7fd367?d=mm


    Jun 14, 2017 22:13

    I used to have this issue, and I had success after upgrading Android SDK, Unity, and then finally JDK.
    I didn't even have terribly old versions (all within 6 months), but upgrading them still to the latest versions solved the issue for me.

  10. 36f94c6bf3422c1451c3c8c39135f319?d=mm


    Jun 09, 2017 08:46

    I installed 5.6.1p2 - and the issue persists

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.