Search Issue Tracker

Fixed in 2017.1.0f3

Fixed in 5.4, 5.5, 5.6

Votes

39

Found in

5.5.2f1

2017.2.0f3

Issue ID

888859

Regression

Yes

Android Build fails when the latest Android SDK Tools 25.3.1 version is used

Android

-

How to reproduce:
1. Update Android SDK Tools to 25.3.1
- In Mac open Android Studio -> Check for updates and update Android Studio version (might be not necessary)
- In Android Studio -> Preferences -> Appearance & Behavior -> System Settings -> Android SDK -> SDK Tools
2. Create a new Unity project
3. Build and run on Android device
Result: Build fails "CommandInvokationFailure: Unable to list target platforms. Please make sure the android sdk path is correct. See the Console for more details. ..."

Reproducible: 5.5.2p2, 5.6.0b11, 2017.1.0a3

Note: I haven't been able to reproduce this issue on Windows machine. As after update via Android Studio, SDK Manager still doesn't see SDK Tools 25.3.1 version and uses 25.2.5

Workaround for the customers.

1) just open https://developer.android.com/studio/index.html
2) scroll down to the bottom of that page
3) go to downloads
4) scroll down to the bottom of that page
5) find Windows "tools_r25.2.3-windows.zip" download and unzip it
5) find MacOSX "tools_r25.2.3-macosx.zip" download and unzip it.
6) In the SDK path replace the tools folder.

FIXED:
Unity versions: 5.4.5p2, 5.5.3p3, 5.6.0p3, 2017.1.0b3
SDK Tools have to be updated to 26.x.x

Comments (165)

  1. Fac6fe97371c222d1f5bc394289f9618?d=mm

    VickySmalley

    Jun 07, 2017 15:14

    I'm also finding that this is NOT fixed in 5.4.5p2 on mac, also getting the problem with merging manifests.

  2. 26cee5a0c17a97aac8e38e9da93c8ca3?d=mm

    MichiealO

    May 31, 2017 21:32

    @JGWINNER - Thank you for this... This morning, I screwed over my ability to make Android games courtesy of another post.
    @UnityTechnologies - For this issue supposedly being "Fixed" according to Unity Technologies, I sure do seem to have an issue with it not being able to build without getting the error that everyone else gets... And, in 5.6.1f, I would think that it would be fixed by now? I mean, this has been an issue since early versions of Unity 4!!!

    So, add all 10 of my votes to Unity Technologies ACTUALLY fixing this issue, rather than backburner-ing it again.

  3. 72383cf4b2d2e0c61b9cf1c316dc4c86?d=mm

    hixiaohe

    May 29, 2017 04:54

    hello, I am using unity5.6.1f1(64bit) for Windows 10.
    I also met the merge issue.
    =======================================================
    Merging manifest with lower AndroidManifest.xml:2:1-8:12
    Merging application with lower AndroidManifest.xml:3:3-5:17
    C:\Users\kaennkyou\Documents\gearvr001\Temp\StagingArea\AndroidManifest-main.xml:4:125-150 Error:
    Attribute application@debuggable value=(true) from AndroidManifest-main.xml:4:125-150
    is also present at AndroidManifest.xml:3:148-174 value=(false).
    Suggestion: add 'tools:replace="android:debuggable"' to <application> element at AndroidManifest-main.xml:4:3-12:17 to override.
    C:\Users\kaennkyou\Documents\gearvr001\Temp\StagingArea\AndroidManifest-main.xml:4:16-57 Error:
    Attribute application@theme value=(@style/UnityThemeSelector) from AndroidManifest-main.xml:4:16-57
    is also present at AndroidManifest.xml:3:83-147 value=(@android:style/Theme.Black.NoTitleBar.Fullscreen).
    Suggestion: add 'tools:replace="android:theme"' to <application> element at AndroidManifest-main.xml:4:3-12:17 to override.
    ===============================================

    It is weird, it automatically create AndroidManifest-main in myproject\Temp\StagingArea\
    and AndroidManifest in myproject\Temp\StagingArea\android-libraries\OVRPlugin
    but in the two AndroidManifests one "application android:debuggable="false" android:theme="@android:style/Theme.Black.NoTitleBar.Fullscreen" (in OVRPlugin)
    and another is <application android:debuggable="true" android:label="@string/app_name" android:icon="@drawable/app_icon" android:theme="@style/UnityThemeSelector">

    they are conflicts, why to create the conflicts file I dont understand.
    I tried @ JAZZPABLOMAY 10, 2017 03:59 solution, but it still does not work.
    It seems it does not read the file I created in Assets/Plugins/Android.

    any help will be very appreciated.
    Thank you.

  4. 1c49288d112cd7e903a10e81a69c78db?d=mm

    Dave-Hampson

    May 24, 2017 14:45

    This issue should be fixed in:
    5.4.5p2 and higher
    5.5.3p3 and higher
    5.6.0p3 and higher
    and 2017.1 beta 5 and higher

  5. 7cbd817418ce468b875b90077e86ad66?d=mm

    barney_devrookie

    May 22, 2017 04:00

    I can't find the "tools_r25.2.3-windows.zip" file . All i found was "sdk-tools-windows-3859397.zip".
    Please help me, I don't know what to do, my unity is up to date but gives me the error "Unable to list target platforms".

  6. 0d50ffc5b14c51659dd9978857ec05fe?d=mm

    Jack1011

    May 14, 2017 15:58

    It is FIXED in 5.6.0p4 !!!

  7. 0d50ffc5b14c51659dd9978857ec05fe?d=mm

    Jack1011

    May 14, 2017 15:03

    I have 5.6.0p3 but still have this error. I also downloaded latest "Android SDK Tools" 26.0.2 and restart everything but still have "Error:Invalid command manifmerger". I see no other choices than try with the 2017.1.0b3 ...

  8. F9806e9e40149354e1b49cca31df707e?d=mm

    PeterD

    May 12, 2017 15:20

    The merge issue is a weird one and I found that it was to do with the way Unity is creating the manifest file in the temp folder.

    Try adding this default androidManifest.xml to your project under plugins/Android remembering to change the package name and remove any unwanted permissions. The issue seems to come from there being no manifest file to actually merge with and also (when you do add the manifest) there may then be issues with some manifest files in your project (in the other libs and plugins) using incorrect icon references.

    <?xml version="1.0" encoding="UTF-8"?>
    <manifest xmlns:android="http://schemas.android.com/apk/res/android"
    xmlns:tools="http://schemas.android.com/tools"
    android:installLocation="preferExternal"
    package="com.yourpackagenamehere"
    android:versionName="2.0"
    android:versionCode="2">
    <supports-screens android:smallScreens="true" android:normalScreens="true" android:largeScreens="true" android:xlargeScreens="true" android:anyDensity="true" />
    <uses-feature android:glEsVersion="0x00020000" />
    <uses-sdk android:minSdkVersion="19" android:targetSdkVersion="25" />
    <application android:icon="@drawable/app_icon">
    <activity android:name="com.unity3d.player.UnityPlayerActivity" android:label="@string/app_name" android:configChanges="fontScale|keyboard|keyboardHidden|locale|mnc|mcc|navigation|orientation|screenLayout|screenSize|smallestScreenSize|uiMode|touchscreen" android:launchMode="singleTask" android:screenOrientation="landscape">
    <meta-data android:name="unityplayer.ForwardNativeEventsToDalvik" android:value="true" />
    <intent-filter>
    <action android:name="android.intent.action.MAIN" />
    <category android:name="android.intent.category.LAUNCHER" />
    </intent-filter>
    </activity>
    </application>
    <uses-permission android:name="android.permission.INTERNET" />
    <uses-permission android:name="android.permission.VIBRATE" />
    <uses-permission android:name="android.permission.GET_TASKS" />
    <uses-permission android:name="android.permission.RECEIVE_BOOT_COMPLETED" />
    <uses-permission android:name="android.permission.WRITE_EXTERNAL_STORAGE" />
    <uses-permission android:name="android.permission.ACCESS_WIFI_STATE" />
    <uses-permission android:name="com.android.vending.CHECK_LICENSE" />
    </manifest>

  9. Df1a22687df368a376272c76a32c4703?d=mm

    Evaldas_Unity

    May 11, 2017 16:24

    Hello everyone,

    The issue has been fixed and the issue tracker above has been updated as to not cause confusion.

    However, with the newest SDK/Build tools we have another issue - Merging manifest files.
    https://issuetracker.unity3d.com/issues/the-project-does-not-build-on-android-platform-using-the-updated-android-sdk-tools-26-dot-0-during-the-merging-manifest-files

    We patched it up a bit in 5.6.0p4, but building Android Oculus is still a no go : (
    We are working on it : )

  10. Ab175e816c63dbf606e5c3c6afa14410?d=mm

    Amir-Ward

    May 11, 2017 03:58

    yeah gee thanks unity devs, did you even test the fix before releasing it? I'm starting to think I should ask for a refund for my pro license, I've just spent a whole week working through unity bugs because you guys don't seem to give a toss anymore

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.