Search Issue Tracker

Fixed in 2017.1.0f3

Fixed in 5.4, 5.5, 5.6



Found in



Issue ID




Android Build fails when the latest Android SDK Tools 25.3.1 version is used



How to reproduce:
1. Update Android SDK Tools to 25.3.1
- In Mac open Android Studio -> Check for updates and update Android Studio version (might be not necessary)
- In Android Studio -> Preferences -> Appearance & Behavior -> System Settings -> Android SDK -> SDK Tools
2. Create a new Unity project
3. Build and run on Android device
Result: Build fails "CommandInvokationFailure: Unable to list target platforms. Please make sure the android sdk path is correct. See the Console for more details. ..."

Reproducible: 5.5.2p2, 5.6.0b11, 2017.1.0a3

Note: I haven't been able to reproduce this issue on Windows machine. As after update via Android Studio, SDK Manager still doesn't see SDK Tools 25.3.1 version and uses 25.2.5

Workaround for the customers.

1) just open
2) scroll down to the bottom of that page
3) go to downloads
4) scroll down to the bottom of that page
5) find Windows "" download and unzip it
5) find MacOSX "" download and unzip it.
6) In the SDK path replace the tools folder.

Unity versions: 5.4.5p2, 5.5.3p3, 5.6.0p3, 2017.1.0b3
SDK Tools have to be updated to 26.x.x

Comments (165)

  1. 82f083514552ea9ee3856bd9ca6ea770?d=mm


    Oct 04, 2017 03:27

    Yes...still in 5.6.3p2. JDK 8 or 9, no difference. Going backwards fixed it, but yes, please fix this Unity!

  2. 919dfcb032e623eda0554d17a6071a1f?d=mm


    Oct 01, 2017 22:02

    I can't believe this is still marked as fixed and yet the above work around is the only "Fix" that actually works. . . COME ON UNITY... FIGURE THIS OUT FOR REAL.

  3. 41d4487df438c462fbdacfc18f4a3ae5?d=mm


    Sep 26, 2017 13:49

    Yip - still in Still in 5.6.3p2 and using java jdk 9

  4. 222be44cebf1dbc67814f2667c04ba98?d=mm


    Sep 24, 2017 18:37

    Still in 5.6.3p2 and using java jdk 9

  5. Fa140c330bf85dc80801d3ac8a4a69ff?d=mm


    Sep 06, 2017 08:06

    This is still an issue in 2017.1.1f1.

    I'm trying to build the Oculus Unity Utilities and the only way that I've been able to build an apk was to use the file.

  6. 97f02b6340d8512f120f51abf73c5b27?d=mm


    Aug 27, 2017 20:19

    Yes, definitely still present in the latest Unity, just updated to 2017.1.0f3 and had the same issue. Only difference my error message when trying to build just an empty project (with android a VR supported) is "Unable to merge android manifests". The same workaround fixed it. The same workaround also fixed an unwanted READ_PHONE_STATE permission automatically added with no reason. replacing the android tool folder now removed this otherwise unremovable permission that warned user that my app "wants to make phone calls" or something silly like that.

  7. 26ab5abf06d6bfdf070b30aef3574301?d=mm


    Aug 07, 2017 21:24

    I believe I have found a resolution to this for the mean time. Look through your {Project-Dir}/Temp/StagingArea/android-libraries and see if any of the plugins contain an AndroidManifest.xml with an <application> tag containing conflicting attributes. The problem seems to lie in the {Assets}/Plugins/UnityPurchasing/Bin/Android, the plugins contain application attributes that'll conflict with the master AndroidManifest. At the moment, I'm able to build without issue after deleting the {Assets}/Plugins/UnityPurchasing/Bin/Android folder. But, this creates another issue with not having IAP working with google play. Hope this gets resolved soon.

  8. 094805ab3f71a3220a5f4fdf6ac7762c?d=mm


    Aug 04, 2017 18:00

    Same problem with the current version 2017.1.0f3 and the android sdk 26

  9. Daa3d711d25665bb1d11a2c71a805005?d=mm


    Aug 01, 2017 18:58

    I upgraded to sdk tools to 26.0.2 and got another problem that unity cannot merge manifest.
    I fixed this problem by replacing the "tools" folder with tools_r25.2.3 (Studio > tools)


  10. Fbff946719d615a4d7775e055740ec94?d=mm


    Jul 31, 2017 13:36

    I've found the error on Unity 2017.1.0f3. It's solved by the previous workaround.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.