Search Issue Tracker

Fixed in 2017.1.0f3

Fixed in 5.4.X, 5.5.X, 5.6.X



Found in



Issue ID




Android Build fails when the latest Android SDK Tools 25.3.1 version is used



How to reproduce:
1. Update Android SDK Tools to 25.3.1
- In Mac open Android Studio -> Check for updates and update Android Studio version (might be not necessary)
- In Android Studio -> Preferences -> Appearance & Behavior -> System Settings -> Android SDK -> SDK Tools
2. Create a new Unity project
3. Build and run on Android device
Result: Build fails "CommandInvokationFailure: Unable to list target platforms. Please make sure the android sdk path is correct. See the Console for more details. ..."

Reproducible: 5.5.2p2, 5.6.0b11, 2017.1.0a3

Note: I haven't been able to reproduce this issue on Windows machine. As after update via Android Studio, SDK Manager still doesn't see SDK Tools 25.3.1 version and uses 25.2.5

Workaround for the customers.

1) just open
2) scroll down to the bottom of that page
3) go to downloads
4) scroll down to the bottom of that page
5) find Windows "" download and unzip it
5) find MacOSX "" download and unzip it.
6) In the SDK path replace the tools folder.

Unity versions: 5.4.5p2, 5.5.3p3, 5.6.0p3, 2017.1.0b3
SDK Tools have to be updated to 26.x.x

Comments (171)

  1. peeyush_unity

    Apr 04, 2018 11:24


    We have a legacy project going on and its in 5.2.5f and we can not update unity version. Android build is not working on oreo 8 and a blank black screen shown at the launch. When debugging it shows some permission issues.
    "04-04 16:02:06.858 25011 25011 E Unity : Unable to query for permission: Fragment null must be a public static class to be properly recreated from instance state.
    04-04 16:02:07.128 773 931 I ActivityManager: Displayed com.learndirectenglish.lde/com.unity3d.player.UnityPlayerNativeActivity: +4s283ms
    I got to know that this is a common problem but unity is not giving support for older versions. Please release a support for unity 5.2.5f as we are paying you for unity plus. You can not withdraw support like that. Please release a patch for unity 5.2.5.

  2. mohsinaaa

    Apr 02, 2018 09:55

    I Have deleted the 24.0.0 build tools folder from Android\sdk\build-tools and it's working

  3. ZoidbergForPresident

    Mar 30, 2018 14:46

    Getting this error too with 2017.4 (and I just updated android studio and java sdk)

    C:/Program Files/Java/jdk-10

  4. Bibbios

    Mar 16, 2018 12:03

    WORKED FOR ME. Windows 10 64bit, Unity 2017.3.1f1, build-tools 25.0.3, jdk1.8.0_161 (Java SE Development Kit 8 Update 161). I also unistalled all the next versions of build-tools and jdk (in my case these were build-tools 26.0.2, 27.0.3, 28.0.0-rc1 and Java SE Development kit 9).

  5. JustABuck

    Mar 03, 2018 19:39

    In case any one still has this problem, try uninstalling Java 9 from you machine and re-installing java 8.

    Based on what happened to me, this error "CommandInvokationFailure: Unable to list target platforms. Please make sure the android sdk path is correct. See the Console for more details." is as a result of trying to run a .bat file that you can attempt to run outside of unity, so if you can't run it neither can unity.

  6. DTFun

    Feb 22, 2018 22:34

    Response below worked for me:

    FEB 09, 2018 11:42

  7. eSoTek

    Feb 22, 2018 10:17

    I have same Problem with SDK 25.3.1. or 26.1.1. PLEASE UPDATE THIS PROBLEM !!!!

  8. pesahov

    Feb 20, 2018 16:36

    it's working with Tools 26.1.1 version on Unity 2017.3.p1

  9. FaberVi

    Feb 20, 2018 01:38

    Same problem on 2017.3.1p1

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.