Search Issue Tracker

Fixed in 2018.1.X

Fixed in 5.6.X, 2017.1.X, 2017.2.X, 2017.3.X, 2017.4.X



Found in


Issue ID




"Assertion failed: TLS Allocator ALLOC_TEMP_THREAD..." error is shown after building the project for iOS'



To reproduce:

1. Create a new project
2. Build it for iOS
3. Observe the console after the build has finished

Expected: no assertion errors are shown after building the project for iOS

Reproduced in 5.6.0a2, 5.6.1p4, 2017.1.0b8, 2017.2.0a4
Did not reproduced in 5.5.4f1, 5.6.0a1
Regression introduced in 5.6.0a2
Not reproducible in 2017.3.0a3

Comments (130)

  1. Mahgo

    Feb 19, 2018 00:41

    Issue present for me on 2017.3.1f1

  2. GMR101

    Feb 18, 2018 21:27

    Issue still present in 2017.3.0p3.

  3. Bilgisoft

    Feb 09, 2018 07:04

    I solved this error. You must change .net option in user preference .net 3.5 to .net 4.6.

  4. TheLZR

    Feb 08, 2018 18:34

    Still a problem on an Android project on Unity 2017.3 . Fixed it by disabling "Crunch Compression" in all the textures and restarting Unity.

  5. GeorgeCH

    Feb 08, 2018 18:07

    Would love to see it fixed, since it makes the profiler useless after every build, forcing a Unity restart.

  6. alior

    Feb 07, 2018 06:49

    The same issue. Removing crunch compression for ETC2 seems to help, but you should realy fix the issue.

  7. Gokuofuin

    Feb 05, 2018 18:33

    Unity 2017.3.0f3 has this error as well.

  8. Artyom-Abgaryan

    Feb 02, 2018 09:41

    Getting this on 17.3.f3

  9. jestergames

    Feb 01, 2018 15:58

    My solution: Some old images had Crunched in its format. I removed all of these by overriding for pc and android. Restarted unity and I never seen this error again!!

    Now ready to build Jesters Poker to Steam!

  10. misher

    Feb 01, 2018 11:33

    Possible cause of error:
    Trying to modify MonoBehavior and it's children Objects before Start() method.
    I had to rewrite some code to fix this issue to make sure no manipulations on MonoBehaviour are done before Start().
    Important note: Errors persist till system restart. YOU NEED TO RESTART WINDOWS.

    I had this error in ALL unity versions, I tried to remove library folder, VS solution files, erase completly and resync from collab, deleting unity configuration files - nothing helped me till I modified my code.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.