Search Issue Tracker

Fixed in 2018.1.X

Fixed in 5.6.X, 2017.1.X, 2017.2.X, 2017.3.X, 2017.4.X



Found in


Issue ID




"Assertion failed: TLS Allocator ALLOC_TEMP_THREAD..." error is shown after building the project for iOS'



To reproduce:

1. Create a new project
2. Build it for iOS
3. Observe the console after the build has finished

Expected: no assertion errors are shown after building the project for iOS

Reproduced in 5.6.0a2, 5.6.1p4, 2017.1.0b8, 2017.2.0a4
Did not reproduced in 5.5.4f1, 5.6.0a1
Regression introduced in 5.6.0a2
Not reproducible in 2017.3.0a3

Comments (130)

  1. michielMV

    Mar 29, 2018 13:08

    Fixed this issue on 2017.3.0f3. Toggled off Crunch Compression on all images, then deleted Library and UnityPackageManager. When I switched platform to Android again, the error was gone.

  2. armleghead

    Mar 06, 2018 14:14

    I got this error after switching my project to android and building a apk, unity 2017.3.0f3

  3. Egil-Sandfeld

    Mar 05, 2018 12:23

    Dang, that is, it actually stopped the error as I was running the Windows platform in build settings. Once I switched back to Android, the issue came back.

  4. Egil-Sandfeld

    Mar 05, 2018 12:15

    I fixed this issue by deleting the following folders in my project:


    I restarted, and the error did not spawn any longer.

    Before this, I tried Bilgisoft's solution which did not help.

  5. info_unity94

    Feb 28, 2018 10:58

    Does anybody solved this issue?
    I did not find any solution for the building problem for iOS in Unity also by installing the most recent patches released by Unity team

    Thanks to everybody

  6. DAVcoHL

    Feb 22, 2018 10:52

    In 2017.3.1f1 I am seeing this error when setting "PlayerSettings.iOS.iOSManualProvisioningProfileID".

    Repro'd on both Win10 and Win7.

    Everything seems to continue to work fine but, once this has occurred, editor updates will cause the messages to spam the console, requiring a Unity restart to clear.

  7. MaskedMouse

    Feb 21, 2018 11:28

    In my previous comment what I meant with "they don't clear their native arrays in the process" I meant Unity

  8. MaskedMouse

    Feb 21, 2018 11:27

    It happens on Unity 2017.3.1p1
    fresh project -> build for iOS -> TLS allocator error afterwards.

    It is incredibly annoying if you want to build and then debug some things in the editor because the log is getting spammed. So even if it is a "minor / comestic" issue, it is interfering with debugging.
    Slowing down debugging after a build for iOS.

    For those who said removing crunch compression works. Thats a seperate TLS allocator issue.
    They probably don't clear their native arrays properly somewhere in the process.
    I did not have this issue for Android builds when using crunch compression for ETC2.

  9. CrazyPhysics

    Feb 19, 2018 14:22

    Same.. please fix :)

  10. Mahgo

    Feb 19, 2018 02:58

    This occurs in the editor regardless of platform. And it never used to happen but started happening more recently.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.