Search Issue Tracker

Fixed in 2018.1.X

Fixed in 5.6.X, 2017.1.X, 2017.2.X, 2017.3.X, 2017.4.X



Found in


Issue ID




"Assertion failed: TLS Allocator ALLOC_TEMP_THREAD..." error is shown after building the project for iOS'



To reproduce:

1. Create a new project
2. Build it for iOS
3. Observe the console after the build has finished

Expected: no assertion errors are shown after building the project for iOS

Reproduced in 5.6.0a2, 5.6.1p4, 2017.1.0b8, 2017.2.0a4
Did not reproduced in 5.5.4f1, 5.6.0a1
Regression introduced in 5.6.0a2
Not reproducible in 2017.3.0a3

Comments (130)

  1. rattlesnake

    Dec 22, 2017 09:18

    Yes in fact, as soon as you add crunch compression, you get the error.
    Thank you unity for telling us to use your great new crunch compression version :

  2. m0guz

    Dec 22, 2017 04:14

    @RATTLESNAKE 's answer solved my problem.

  3. hippogames

    Dec 21, 2017 15:28

    Same problem after updating to 2017.3 ((((((((((((

  4. heliojmsemedo

    Dec 21, 2017 14:22

    Faced this issue 2017.3.0f3, had a root point: a small texture (128x128) with crunch compression enabled.

    After disabling the compression and restarting Unity, the log disappeared.

    (To find out what texture was causing the issue I had to create a new project and start importing textures from main project until the issue occured, I thought it had to do with a texture due to RATTLESNAKE's comment)

  5. alexchandriyaa

    Dec 21, 2017 07:10

    same problem in 2017.2.0f3

  6. LouisHong

    Dec 20, 2017 23:45

    2017.3 Windows 10 64

    Building iOS project results in the console being spammed with ALLOC_TEMP_THREAD errors.
    This happens on an empty/clean project. Default settings.
    The only fix is to restart Unity after every build.

  7. rattlesnake

    Dec 20, 2017 16:16

    Same thing on 2017.3.0.f3 with android.
    Reimport All didn't resolved the issue...
    So I tested ton of things and one thing worked to me :

    At the root of your project,within the Project view/search bar,
    - type (in order to display all the textures):
    - t:texture2d
    - Select all your textures and apply the compression "normal quality" and use Crunch compression => No

    After this big reset you can change back your quality settings :)

  8. Protozoaire

    Dec 19, 2017 15:32

    iOS Build on 201.1.0f3:
    Assertion failed: TLS Allocator ALLOC_TEMP_THREAD, underlying allocator ALLOC_TEMP_THREAD has unfreed allocations

  9. amaceikaCortina

    Dec 18, 2017 16:33

    I also have this in 2017.2.0f3 any time I build for iOS. Has there been a patch or any word on a fix?

  10. halken

    Dec 16, 2017 22:28

    Same issue for me. Unity 2017.2.0f3

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.