Search Issue Tracker

Fixed in 2018.1.X

Fixed in 5.6.X, 2017.1.X, 2017.2.X, 2017.3.X, 2017.4.X



Found in


Issue ID




"Assertion failed: TLS Allocator ALLOC_TEMP_THREAD..." error is shown after building the project for iOS'



To reproduce:

1. Create a new project
2. Build it for iOS
3. Observe the console after the build has finished

Expected: no assertion errors are shown after building the project for iOS

Reproduced in 5.6.0a2, 5.6.1p4, 2017.1.0b8, 2017.2.0a4
Did not reproduced in 5.5.4f1, 5.6.0a1
Regression introduced in 5.6.0a2
Not reproducible in 2017.3.0a3

Comments (129)

  1. Unplug

    Jan 24, 2018 14:53

    2017.3.0.f3 here and i recently got this error. When i press play i get a few "Allocation of 78 bytes at 0000000009945240" (and other close number) and then the Assetion failed : TLS Allocator ALLOC_TEMP_THREAD, underlying allocator ALLOC_THEMP_THREAD has unfreed allocation, size 468

  2. Jbrandan

    Jan 17, 2018 22:05

    Assertion failed: TLS Allocator ALLOC_TEMP_THREAD, underlying allocator ALLOC_TEMP_THREAD has unfreed allocations, size 1245664

    Unity 2017.3.0f3

  3. NinjaCalvin

    Jan 17, 2018 20:15

    Unity 5.6.3

  4. jfperusse_bhvr

    Jan 17, 2018 18:20

    Same in 2017.3.0p2.

  5. leeyisan

    Jan 15, 2018 02:21

    Same here, Version 2017.3.0f3 in editor android Assertion failed: TLS Allocator ALLOC_TEMP_THREAD.......... Never stops!!!!!!!!!!!!!!
    but switch pc is ok.... plz fix it ASAP!!!!

  6. Gamersinitfusion

    Jan 12, 2018 06:56

    I had this same issue in version 2017.3.0f3 and solved it by deleting everything from my project folder (in the explorer) EXCEPT:

    - Assets
    - ProjectSettings
    - Any Visual Studio Project/Solution Files

  7. Chewook

    Jan 11, 2018 18:02

    I get this issue as soon as I click the play button or build the solution for iOS. Running on Windows 10, Unity version 2017.3.0f3

    TLS Allocator ALLOC_TEMP_THREAD, underlying allocator ALLOC_TEMP_THREAD has unfreed allocations

    I tried re-importing all assets and that didn't help. I can still build to iOS, but it makes debugging nearly impossible.

  8. Todd-Wahoske

    Jan 10, 2018 20:52

    *Using Unity for Win
    * Reverted the Crunch submission, restarted Unity and the error is gone.
    * The error occurred while resizing the game window and running the game in editor (windows)

  9. Todd-Wahoske

    Jan 10, 2018 20:44

    Repro in Unity 2017.3.0f3 with (Build Settings) platform set to Android. Did not occur when platform was set to PC/Mac & Linux Standalone.

    *Note this happened *right* after submitting Crunch textures for the project on PC/Android/iOS.

    My estimated guesses:
    * crunching small textures is bad? (<32x32 to 128x128)
    * crunching certain types of textures is bad (UI, particles, )
    * crunching atlas packed (tagged) textures with different crunch settings is bad
    * it's Trump's fault? ;) *cough*

    Was super duper looking forward to Crunch results, so hoping this can get fixed for the next update. thx!

  10. cain06

    Jan 10, 2018 15:35

    2017.3 just to clarify

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.