Search Issue Tracker

Fixed in 2018.1.X

Fixed in 5.6.X, 2017.1.X, 2017.2.X, 2017.3.X, 2017.4.X



Found in


Issue ID




"Assertion failed: TLS Allocator ALLOC_TEMP_THREAD..." error is shown after building the project for iOS'



To reproduce:

1. Create a new project
2. Build it for iOS
3. Observe the console after the build has finished

Expected: no assertion errors are shown after building the project for iOS

Reproduced in 5.6.0a2, 5.6.1p4, 2017.1.0b8, 2017.2.0a4
Did not reproduced in 5.5.4f1, 5.6.0a1
Regression introduced in 5.6.0a2
Not reproducible in 2017.3.0a3

Comments (130)

  1. TheosaurusMagnus

    Apr 12, 2020 19:34

    Just happened in 2019.3.9f1

  2. cello_91

    Feb 13, 2019 07:42

    2018.3.5f1 here and i HAD the same error.
    I corrected it by trying these steps (can't tell for sure if only the last corrected it):

    1) Edit -> GI Cache -> Clean Cache
    2) Edit -> Project Setting -> Player -> Configuration -> .Net 4.x Equivalent
    3) Rename the "obj" folder I had in my project under the Assets to "objFiles".

    Most likely the third step solved it!

  3. adar_unity

    Oct 16, 2018 12:27

    issue popped up in 2018 1.2.1f
    happens in the editor, and Unity won't build for android because of it

  4. Mechsoul

    Sep 17, 2018 03:36

    I'm currently using 2017.3.1.f1, and so far going to Edit/Preferences/GI Cache, and selecting Clean Cache before building has been working for me.

  5. Portalarium

    Sep 06, 2018 15:36

    This is not fixed in 2018.1.7. Multiple people on our team are seeing this.

  6. browne11

    Aug 31, 2018 21:02

    This issue popped up using 2018.1.3.f1.

    Restart cleared it. Will post back if it returns!

  7. arunvutnoori

    Jul 07, 2018 15:51

    Is this problem still not solved ??? Still not able to build for IOS , but whereas works fine for android,standalone.

  8. Andragorn

    May 14, 2018 03:38

    Happens to my project all the time.
    Unity version 2017.3.1f1

    Hope it will be fixed?...

  9. pedro_slipknot

    Apr 06, 2018 00:16


    I got the same error, but I was NOT using any crunched images.

    So I closed Unity and opened it again, and the error (at least for now) is gone.

    Oh, and I got the error doing an Android project...

  10. fourthWallArtist

    Mar 30, 2018 16:50

    If you have a big project do not delete Library folder it will revert the platform. It will take long time to load unity and switch back to the platform you had set. If you have lots of textures you will have to wait a long time.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.