Search Issue Tracker

Fixed in 2017.2.0f3

Fixed in 5.6.X, 2017.1.X

Votes

131

Found in

5.6.0f3

Issue ID

899009

Regression

Yes

"In order to call GetTransformInfoExpectUpToDate..." error message appears while toggling Skinned Mesh Renderer component

Graphics - General

-

How to reproduce:
1. Create a new project
2. Change "Directional Light" type from Directional to Spot, make sure that it's Shadow Type settings would be set to Soft or Hard Shadows
3. Add a 3D Object as a child of "Directional Light" GameObject
4. Add a Skinned Mesh Renderer component to a 3D Object
5. Create an empty GameObject as a child of 3D Object
6. Go back to 3D Object Inspector settings and set an empty GameObject as a Root Bone
7. Toggle on and off 3D Objects Skinned Mesh Renderer component repeatedly

Expected result: No error is appearing
Actual result: "In order to call GetTransformInfoExpectUpToDate, RendererUpdateManager.UpdateAll must be called first." error message appears in the Console

Note: The important parts of this bug reproduction are Spotlight, Realtime/Mixed Shadows(hard/soft), "Skinned Mesh Renderer" with "Root Bone" assigned

Regression introduced in - 5.6.0b8
Reproducible with - 2017.1.0b1, 5.6.0f3, 5.6.0b8
Not reproducible with - 5.6.0b7, 5.5.3f1, 5.4.5f1

--------------
Fixed in 2017.2.0a4. Backports to 5.6 and 2017.1 were made.

Comments (66)

  1. B650c41010689c70982c7c332686dae7?d=mm

    Skyway-Interactive

    May 18, 2017 02:19

    Had this appear for the first time in 5.6.1f1 I had not seen this in 5.6.0f3. Turning a spot light's shadows from none to soft I could recreate the error every time.

  2. 29a0a6c72cf3d87617183a65d1ff80b4?d=mm

    Ruhan-

    May 16, 2017 13:08

    Still occurring in 5.6.1f1
    I know it's not not a fix on the change log but there are other SkinnedMeshRenderer related fixes in it so thought I'd give it a shot.

    We can only hope it gets fixed on a patch release of 5.6.1 for now :\ but otherwise 5.6.2f1 will definitely take a while...

  3. Eae7409b3699c0f0a9663911ede72870?d=mm

    ferruccio

    May 15, 2017 15:50

    Getting the same error. I do not use a spotlight but I use interpolation on some rigidbodies. Deactivating interpolation solves the issue, but I really need interpolation.

  4. D40c0bba987945b0a37af0a9fb26d7e0?d=mm

    wavebbs

    May 09, 2017 10:37

    Hi!!!
    I found call Commandbuffer.drawRender() will always case this bug!!!

  5. 11e13d311c33b770acd73272eb8dbf2e?d=mm

    pixelgriffin

    May 08, 2017 03:14

    I can confirm this issue still exists in 5.6.0f3. However, I have no spotlights. Despite what others might be saying AFAIK my errors are resulting from interpolation on a rigidbody.

    Using SteamVR's interaction system moving an object erratically and letting go a few times will cause these errors to spew out.

    I have confirmed that this ONLY happens when the object's rigidbody interpolation is set to something other than none after being let go of.

    Interestingly enough, when the object has interpolation on its rigidbody will not interact with other collision meshes, it is effectively non existent in terms of colliders, despite the colliders still maintaining their proper properties.

  6. Fee80ee83b6fbca225dee1b8270770fc?d=mm

    Hazneliel

    May 07, 2017 22:37

    Also want to confirm that this is not an interpolation issue, that one was fixed in https://issuetracker.unity3d.com/issues/errors-message-at-editor-play

    This issue is specifically for spotlights since disabling them resolves the issue.

  7. Fee80ee83b6fbca225dee1b8270770fc?d=mm

    Hazneliel

    May 07, 2017 21:15

    Im seeing this issue on 5.6.0 with a realtime spotlight. Any workaround?

  8. 828bda7339db5455100ef72c46584ba4?d=mm

    polypandas

    May 05, 2017 02:23

    Updated from 5.5 to 5.6.0f3 and now get this error. I have a rigid body that is attached to a characters hand. The rigid body has interpolation. The character animates its arms but now the rigid body no longer stays in place on the hand.

  9. 3a97e0f577a72a29118c1de9fb60d5f7?d=mm

    kloogens

    May 02, 2017 15:50

    This is still rigidbody related. Had a character with an rigidbody attached. Once I removed the RB from the character, it stopped throwing the error. Strange thing though, after I added the RB back to the character with all the same values it worked without any more errors? This is remarkably frustrating and is eating up tons of my time. I'm spending a good 30% of all my productivity fighting Unity bugs.

  10. 99b8bf3fb72dd929da5d3b4f2c9dba0f?d=mm

    v_Jay_v

    May 02, 2017 04:04

    :(

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.