Search Issue Tracker

Fixed in 4.5.X

Votes

225

Found in

4.3.0f2

Issue ID

573949

Regression

No

Stepping out while debugging causes the standalone player to freeze

Mono

-

To reproduce:
1. Build Angry bots x64 standalone on OSX 10.9
2. Put a breakpoint in FreeMovementMotor line 18
3. Pin some variables
4. Attach to player
5. Hit breakpoint, step through some code
5. Player crashes (stack trace attached)

Expected result: Debugging proceeds
Actual result: player freezes

*Note :

The issue is related to Stepping Out when debugging and is fixed. We found another issue related to Stepping Over which has the same result, the player freezing but it only occurs when using Step Over.

Comments (84)

  1. Wenceslao

    Dec 08, 2013 09:19

    On 4.3.1 on OS X Mavericks I can connect the debugger and even stop playing once. After that if I hit play again or try to compile scripts Unity locks up.

  2. froodydude

    Dec 06, 2013 10:37

    I get this on OSX 10.7.5 with Unity 4.3 and Unity 4.3.1.

  3. Socapex

    Dec 05, 2013 19:40

    Still bugged in 4.3.1! Priority 3?????????????????????????? FFS Unity!

  4. PhilippeDu60

    Dec 04, 2013 10:48

    The Debugging in Unity 4.3.1 with Mavericks is impossible for me at the moment. Unity and MD hanging ! Requiring the force-quitting Unity and MD.

  5. eshan-mathur

    Dec 03, 2013 21:52

    And I'm on 4.3.1.

  6. eshan-mathur

    Dec 03, 2013 21:09

    This says fixed, but it is absolutely not fixed for me or anyone on my team. Should I vote on this or will it just be ignored because of it's "fixed" status?

  7. Ciprian

    Dec 02, 2013 22:16

    Updated to 4.3.1 hoping the mono debugger freezing unity will be solved.. No such luck on Mavericks, MBR 2012

  8. broepstorff

    Dec 01, 2013 04:00

    Still happens for me in 4.3.1 + Mavericks on a MBP Early 2011. Makes it impossible to put breakpoints in Start() or Awake() methods

  9. Zincoontrin

    Nov 30, 2013 17:53

    After rebooting the whole machine, it's working again. Sorry but I don't think you have solved the race condition, you probably have just hidden it a little more.

  10. Zincoontrin

    Nov 30, 2013 17:47

    It's happening again in 4.3.1 after the patch. I've been working with it for a day, at first it stopped happening but it's happening again now in the usual workflow:
    - Attach process to unity debugger from Mono
    - Hit "Play" in Unity editor

    I can't understand how it's broken again. Should I reinstall or something??

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.