Search Issue Tracker

Fixed in 4.5.X

Votes

225

Found in

4.3.0f2

Issue ID

573949

Regression

No

Stepping out while debugging causes the standalone player to freeze

Mono

-

To reproduce:
1. Build Angry bots x64 standalone on OSX 10.9
2. Put a breakpoint in FreeMovementMotor line 18
3. Pin some variables
4. Attach to player
5. Hit breakpoint, step through some code
5. Player crashes (stack trace attached)

Expected result: Debugging proceeds
Actual result: player freezes

*Note :

The issue is related to Stepping Out when debugging and is fixed. We found another issue related to Stepping Over which has the same result, the player freezing but it only occurs when using Step Over.

Comments (84)

  1. JKyy

    Jan 30, 2014 13:42

    I would really like to see this issue been fixed. It is very frustrating. Even an info whether the issue is reproducible on Unity Tech's end would be good news. If more info is needed for reproduction, I am sure many us will help. Here is a sampling ( http://pastebin.com/n6De5kJq ) on my Mac done from the Activity Monitor once I have attached to Unity Editor process from the Monodevelop and clicked "Play" in Unity Editor. Unity application is now stuck in non-responding state.

  2. iKonrad

    Jan 30, 2014 11:31

    Thing that is depressing me the most is that we still did not get any official statement from Unity Team.
    Come on, debugging is a crucial part of serious programming - it is a priority 1 since it breaks the regular development workflow! Do something guys.

  3. shloob

    Jan 30, 2014 02:23

    @Unity Devs - This issue is not specific to the repro steps above, it happens with every single one of my projects. Attach MonoDevelop to Unity Run and Debug hit a breakpoint. Stop running and try to run again and Unity becomes unresponsive. Then you must force quit unity, quit monodevelop, then open unity, then open monodevelop. Rinse and repeat, the same every time.

  4. shloob

    Jan 30, 2014 02:17

    Yes please vote for this issue. This makes using Unity extremely frustrating, I can't believe that this is ranked as a Priority 3 issue. It has been happening for several versions, and did not get any better with version Unity 4.3.3f1. Someone please fix this!!!!

  5. Zincoontrin

    Jan 29, 2014 21:18

    SETHK: I'll open a kickstarter campaign for you :)

  6. sethk

    Jan 28, 2014 22:22

    MonoDevelop is open source, so possibly a workaround/fix exists there. Who will donate me some money if I can solve the issue? (half-joking)

  7. FredDeschenes

    Jan 28, 2014 19:44

    Unity 4.3.x
    OSX 10.7.5 (Lion)

    Same issue, cannot but breakpoint (never had any issues with Unity 4.2).

    As IQPierce mentionned, this is a super critical bug. I do not get how the IDE integration can be SO broken (cannot debug, can't even open the correct project most of the time when working on multiple projects at once, etc) on OSX and Windows and this not being a top priority bug. This is turning professional developers away from Unity...

  8. vito-c

    Jan 27, 2014 19:38

    OSX 10.8.5
    Unity 4.3.3f1
    Unity is freezing after running the debugger about 75% of the time. Usually works the first time I run it then if I leave the debugger attached and run the game again unity will freeze

  9. TomD3

    Jan 22, 2014 20:50

    Same here; totally useless on the Mac (Maverick with Unity 4.3.3f1); sometimes it works, sometimes it doesn't. It's not a small problem, it's a showstopper for many people.

    Do we have any kind of workaround?

  10. sdvoynikov

    Jan 22, 2014 01:18

    Have this issue for a long time: when monodevelop connected to editor, editor will freeze when trying to launch play mode. Actual for several versions of Unity, since about 4.2 until current 4.3.3

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.