Search Issue Tracker

Fixed in 4.5.X

Votes

225

Found in

4.3.0f2

Issue ID

573949

Regression

No

Stepping out while debugging causes the standalone player to freeze

Mono

-

To reproduce:
1. Build Angry bots x64 standalone on OSX 10.9
2. Put a breakpoint in FreeMovementMotor line 18
3. Pin some variables
4. Attach to player
5. Hit breakpoint, step through some code
5. Player crashes (stack trace attached)

Expected result: Debugging proceeds
Actual result: player freezes

*Note :

The issue is related to Stepping Out when debugging and is fixed. We found another issue related to Stepping Over which has the same result, the player freezing but it only occurs when using Step Over.

Comments (84)

  1. EBPlayin

    May 05, 2014 22:42

    This crash cost me like five hours of work. It's pathetic that this wasn't tested right.

  2. Andrey-Postelzhuk

    Apr 29, 2014 12:01

    Run application first and then attach the debugger doesn't work.

  3. Andrey-Postelzhuk

    Apr 29, 2014 11:58

    I updated my mac to mavericks (10.9.2) and now I can't debug. Did anybody find workaround?

  4. Steazy

    Apr 24, 2014 21:42

    I'm having the exact same issue I'm seeing described by many many other people.

    MacBook Pro Retina, 15-inch, Late 2013
    2.3 GHz Intel Core i7
    16 GB 1600 MHz DDR3
    NVIDIA GeForce GT 750M 2048 MB
    OS X 10.9.2 (13C64)
    Unity Version 4.3.4f1
    2 External Monitors via Thunderbolt

    Wish I had something new to add other than THIS IS TERRIBLE! Our team upgraded to 4.3.4 from 4.2.2 (which was surprisingly difficult, BTW) under the impression that it would fix this problem... Well, it's better... in about a dozen attempts I can sometimes use the debugger with marginal reliability (frequently simple things fail, like step-into stepping out of the current function *mind blown*). I'm back to using Debug.Logs though, because when the debugger doesn't work (~90% of the time?) it invariably deadlocks Unity and MonoDevelop requiring a force restart and many wasted hours.

    If I worked for Unity, I would be downright embarrassed that an issue like this made it out to consumers for even one release. And it's persisted for over a year across how many releases now? Every dev I work with using this configuration experiences the exact same issue, so the repro rate must be damned near 100%. Take the money you make from selling one license, pick up a used Retina MBP, and WORK FOR A LIVING!

  5. temptest123

    Apr 24, 2014 18:31

    This is still an issue in 4.3.4 and affects our development severely!

  6. AndyMartin458

    Apr 22, 2014 01:27

    Unplugging my second monitor did seem to help me be able to actually attach the debugger for the first time in over a month. When we first went to 4.3.1, everything seemed awesome. We could attach and hit breakpoints without a problem. I think that upgrading from OSX 10.9.1 to 10.9.2 might be the culprit. Upgrading Unity to 4.3.4 would be a huge pain for us, and people still seem to have the issue with that version. Please release 4.3.5 with at least a hacky fix until you release 4.4.0

  7. j1mmie

    Apr 12, 2014 08:33

    Still happens for me in Unity 4.3.4f1

    MacBook Pro
    Retina, 15-inch, Late 2013
    OS X 10.9.2
    2.6 GHz Intel Core i7
    16 GB 1600 MHz DDR3
    NVIDIA GeForce GT 750M 2048 MB

    Disabled Power Nap, App Nap, unplugged external monitors. No effect though - I can't even attach to the debugger after hitting play. Is there any more information I can offer to help resolve the bug?

  8. gmxtian

    Apr 02, 2014 21:44

    Okay, here is a clue. The problem with always locking up on Macbook Pro while debugging seems to be related to using a secondary monitor. When I disconnect the monitor I can still do the work-around method of playing first then attaching the debugger.

  9. gmxtian

    Apr 02, 2014 12:49

    The problem got worse when I got my new Macbook Pro, Retina with the Mavericks (10.9.2) and Unity 4.3.4f1. The workaround of playing Unity first and then attaching the debugger used to work sometimes. Now it never works and Unity locks up right away after attaching the debugger. So this problem has been plaguing me for about a year now. It's issues like this that will drive me to Unreal.

  10. kolchaud

    Mar 31, 2014 08:51

    Dear Unity team,

    Please find us at least a workaround, I'm fed up to write Debug.Log.
    I think the priority should be higher as Debugger is one of the basic tools for decent programing.
    We lost a lot of time.
    Thanks to give us an ETA or a workaround ASAP.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.