Search Issue Tracker

Fixed in 4.5.X



Found in


Issue ID




Stepping out while debugging causes the standalone player to freeze



To reproduce:
1. Build Angry bots x64 standalone on OSX 10.9
2. Put a breakpoint in FreeMovementMotor line 18
3. Pin some variables
4. Attach to player
5. Hit breakpoint, step through some code
5. Player crashes (stack trace attached)

Expected result: Debugging proceeds
Actual result: player freezes

*Note :

The issue is related to Stepping Out when debugging and is fixed. We found another issue related to Stepping Over which has the same result, the player freezing but it only occurs when using Step Over.

Comments (84)

  1. blankatmcard2022

    Mar 17, 2022 00:21

    GET RICH WITH BLANK ATM CARD ... Whatsapp: +18033921735

    I want to testify about Dark Web blank atm cards which can withdraw money from any atm machines around the world. I was very poor before and have no job. I saw so many testimony about how Dark Web Cyber hackers send them the atm blank card and use it to collect money in any atm machine and become rich.( I email them also and they sent me the blank atm card. I have use it to get 250,000 dollars. withdraw the maximum of 5,000 USD daily. Dark Web is giving out the card just to help the poor. Hack and take money directly from any atm machine vault with the use of atm programmed card which runs in automatic mode.

    You can also contact them for the service below

    * Western Union/MoneyGram Transfer Hack

    * Bank Transfer Hack

    * PayPal / Skrill Transfer Hack

    * Crypto Mining Hack

    * CashApp Transfer Hack


    Text & Call or WhatsApp: +18033921735

  2. newonelei

    Jan 18, 2017 08:03

    still happening frequently in 5.5.0p1

  3. Tyrathect

    Aug 25, 2016 02:57

    still happening frequently in 5

  4. senchov

    Jul 13, 2016 16:04

    Not Working on Unity 5.2.2, please fix it

  5. rsodre

    Apr 20, 2015 02:38

    Still happening on Mac OS X 10.9.5, Unity 3D Pro 4.6.3

  6. akenaton

    Mar 23, 2015 16:16

    Still Not Working on Unity 4.3.f1with Monodevelop 4.0.1 on yosemite 10.10.2
    Impossible to attach unity Editor Debugger
    It freezes
    Cannot Cancel too
    Need to kill Monodevelop

  7. _Radagan

    Mar 03, 2015 07:26

    This is not fixed... it's back in Unity 5 RC3 on Yosemite. I can't debug with Monodevelop at all. Freezes on attach every time.

  8. WarbladerToo

    Dec 19, 2014 01:21

    Im on a Mac using Yosemite 10.10 and if restart the machine I can run Unity and start up monodevelop and do debugging just fine. But if Unity (I'm on 4.61 patch 1) crashes and I restarts it it would make monodevelop crash/hang every time I try to attach to the unity process. I have to restart the Mac to make it work again. This is really bad as there is a lot of stuff I have running that needs restarting.

    I also use Sublime Text for editing the source files. it about 1.000.000 times better then monodevelop and its super fast.

  9. seaders

    Dec 03, 2014 17:00

    This was definitely *not* fixed in 4.5, and it is still present in the 4.6.0f3 as well.

    Who decides this is resolved, and stays as such when the community all state the bug is still there? Do we have to create a new bug tracking issues?

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.