Search Issue Tracker

Fixed in 2019.1.5f1

Fixed in 2019.1.X, 2019.2.X

Votes

0

Found in

2019.1.0a5

2019.1.0b8

Issue ID

1143135

Regression

Yes

Image Color cannot be changed via script when Image type is set to Simple

uGUI

-

To reproduce:
1. Open attached project "alphaspritebug.zip", scene "AlphaTest"
2. Enter Play mode
3. Click on the numbered buttons
4. Observe the bottom row of pictures (upper row is correct result)

Expected: Image alpha is changed via script
Actual: alpha is not changed if Image type is set to Simple

Reproduced in: 2019.1.0a5, 2019.1.0f1, 2019.2.0a11
Not reproduced in: 2017.4.25f1, 2018.3.12f1, 2019.1.0a4

Note: other image types do not reproduce the issue

  1. Response avatar

    Resolution Note (fix version 2019.1.5f1):

    Fixed in: 2019.3.0a4, 2019.2.0b4, 2019.1.5f1

Comments (40)

  1. 5a579dd5cbfca9721064c29bd6245df3?d=mm

    spockthegray-mk2

    Aug 27, 2021 20:39

    Still seeing this in 2020.1.9f1!

  2. E3898f4b3e2ca08b65ec922cddba4657?d=mm

    Fr4ncisc0Fr4nc0

    Jan 06, 2021 06:01

    I'm using 2020.1.8f1 and it still happens while trying to change the image color.

  3. 080436a9d70376aab65064b3ecbfa307?d=mm

    rebeccaruva

    Dec 15, 2020 03:05

    reproduced in 2019.4.8f1. While in play mode I can select the image's color and it actually shows the correct color in the pop up...but not in inspector nor the game view itself.

  4. D1294e83d5cde552f24172c5adcff26f?d=mm

    fhecorrea

    Oct 08, 2020 17:23

    It's not fixed in 2019.4.4f1 version. |-(

  5. 6035886a250c5d12c359f1348be69056?d=mm

    VINNUSAURUS

    Aug 23, 2020 07:45

    version 2019.4.8f1 have this problem, text is not updating when changed from code, but if i change it in inspector it is updating.

  6. E718bb27399835a58dc5001e867e7867?d=mm

    msomele

    Aug 18, 2020 23:01

    In 2020.1.0f1 again not fixed

  7. 993ecac2ac86a461edc5c3b3535de1f9?d=mm

    JPBA1984

    Aug 02, 2020 00:59

    not working on 2019.4.1f1, i have a UI slider, the fill object has an image, trying to change its .color property, nothing happens.

  8. B52d135858cfd10865bb6195939a5216?d=mm

    ThorBrigsted

    Jun 18, 2020 21:26

    Still not fixed in 2019.4.0f1

  9. 5cf523bcf84fd17c9de019e1c33184a0?d=mm

    n30b4rt

    May 07, 2020 07:55

    Whoops wasn't aware that the color values were between 0 and 1 not 0 and 255

  10. 5cf523bcf84fd17c9de019e1c33184a0?d=mm

    n30b4rt

    May 07, 2020 07:38

    Are you serious. I'm now on 2019.3.13f1 and this is an issue for me.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.