Search Issue Tracker

Fixed in 2019.1.5f1

Fixed in 2019.1.X, 2019.2.X



Found in



Issue ID




Image Color cannot be changed via script when Image type is set to Simple



To reproduce:
1. Open attached project "", scene "AlphaTest"
2. Enter Play mode
3. Click on the numbered buttons
4. Observe the bottom row of pictures (upper row is correct result)

Expected: Image alpha is changed via script
Actual: alpha is not changed if Image type is set to Simple

Reproduced in: 2019.1.0a5, 2019.1.0f1, 2019.2.0a11
Not reproduced in: 2017.4.25f1, 2018.3.12f1, 2019.1.0a4

Note: other image types do not reproduce the issue

  1. Resolution Note (fix version 2019.1.5f1):

    Fixed in: 2019.3.0a4, 2019.2.0b4, 2019.1.5f1

Comments (47)

  1. roka

    May 15, 2019 18:35

    Are you serious? Unity 2018.3 has been released in December 2018, so we have to wait december 2019 to get this fixed? Really ???

  2. UnityDev_

    May 14, 2019 13:58

    Come on Unity, this is basic functionality! We cannot work for ~6 months for a fix for something so common.

  3. AdamLiu

    May 14, 2019 12:18

    Fixed in Unity 2019.3 ?? I mean, this is a quite common use case right? Unity 2019.2 is still in beta and this is fixed in 2019.3? That is another a few months right? Why are you doing this, Unity? Why?

  4. jannysice

    May 08, 2019 11:38

    I assume that changing sprites via scripts is common, which makes me wonder why this issue does not get prioritized. We swap sprites with code in every place in out game and it just causes malformed images. This is the one reason we did not migrate to Unity 2019 yet.

  5. xlabcz

    May 07, 2019 20:56

    i had that issue on 2 groups of things in 2019.1.0f2, after update to 2019.1.1f1 one of the groups started to work as supposed (all the alpha tweening is displaying correctly), but the other usage where i tween alpha to 0, then change the sprite and tween back to 1 isn't working like before (if I change it from simple to let's say filled it displays but not with simple)

    so i was looking and i found 2 differencies - the not displaying sprite was rect mesh and not in atlas ... so i checked mesh and still no success but when i atlased the sprite it started to display

    i guess the bug was half fixed in update to 2019.1.1f1 but since it works only with atlased sprites (the particular image isn't POT)

  6. AShim-3D

    May 06, 2019 13:37

    Hack to fix: replace from "Image.sprite = Sprite;" to "Image.overrideSprite = Sprite;".

  7. AShim-3D

    May 06, 2019 13:35

    In 2019.1.1f1 same issue...

  8. SnowDaySoftware

    May 05, 2019 15:03

    ETA for a fix? This is a breaking issue for me and it is holding up from releasing updates. Currently on 2019.1.0f2

  9. NotASnack

    May 04, 2019 10:47

    This needs to be not disabled for voting since it has not been fixed yet. I'm trying to vote for this issue to be fixed

  10. LastChaos

    May 04, 2019 07:18

    2019.1.1f1 - still not fixed!

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.