Search Issue Tracker

Fixed in 4.5

Votes

225

Found in

4.3.0f2

Issue ID

573949

Regression

No

Stepping out while debugging causes the standalone player to freeze

Mono

-

To reproduce:
1. Build Angry bots x64 standalone on OSX 10.9
2. Put a breakpoint in FreeMovementMotor line 18
3. Pin some variables
4. Attach to player
5. Hit breakpoint, step through some code
5. Player crashes (stack trace attached)

Expected result: Debugging proceeds
Actual result: player freezes

*Note :

The issue is related to Stepping Out when debugging and is fixed. We found another issue related to Stepping Over which has the same result, the player freezing but it only occurs when using Step Over.

Comments (84)

  1. F193adefff62a8e5d260299be37f9639?d=mm

    meandbreastactives

    May 02, 2020 22:19

  2. 7d4c717db63e54c1980f05cbfd6b2291?d=mm

    adekanmiadeola9

    Dec 27, 2019 21:23

    https://www.happybirthdaysisters.com

    https://www.instructables.com/member/happybirthdaysister72/

    https://www.instructables.com/member/Goodguys001/

    https://www.instructables.com/member/Olulekan01/

    https://www.imdb.com/user/ur111189818/

    http://www.wikidot.com/user:info/oluvictir

    http://www.wikidot.com/user:info/alexist001

    https://social.msdn.microsoft.com/Profile/Birthday%20Wishes

    https://social.msdn.microsoft.com/Profile/Happy%20birthday%20sister

    http://www.folkd.com/user/Olulekan01

    https://network.changemakers.com/profiles/105207008552574564815

    https://network.changemakers.com/profiles/118174859034121218632

    https://www.wantedly.com/users/126196789

    https://forum.teamspeak.com/members/437731-Sweeledwr

    http://hbss.idea.informer.com/

    http://forsisters.idea.informer.com/

    https://thriveglobal.com/authors/olulekan-olufajo

    https://telegra.ph/Birthday-SMS-12-18

    http://impression3d.laposte.fr/en/users/literatureshot

    https://pbase.com/olulekan01/profile

    https://network.changemakers.com/profiles/105207008552574564815

    https://network.changemakers.com/profiles/118174859034121218632

    https://network.changemakers.com/profiles/118368624037159181993

    https://forum.teamspeak.com/members/437731-Sweeledwr

    https://www.mathworks.com/matlabcentral/profile/authors/17117178-olulekan-olufajo

    http://impression3d.laposte.fr/en/users/literatureshot

    https://ko-fi.com/sweetlad

    https://myanimelist.net/profile/Avadalove

    https://myanimelist.net/profile/Sweetlad

    https://www.edocr.com/user/literatureshot

    https://marketplace.whmcs.com/user/victor2199

    http://flgclassifieds.cce.cornell.edu/author/billionaireguy

    http://flgclassifieds.cce.cornell.edu/author/goodboys/

    https://serc.carleton.edu/person/129726.html

    https://www.sbnation.com/users/Olufajo%20Olulekan%20Victor

    https://www.theverge.com/users/Olulekan%20Olunlade

    https://itsmyurls.com/olulekan01

    https://www.businessadviceforum.com/members/olulekan-olufajo.69713/

    https://oxfordbrookes.academia.edu/OlulekanOlufajo

  3. Ab0e8e4539c320322052de897a713493?d=mm

    newonelei

    Jan 18, 2017 08:03

    still happening frequently in 5.5.0p1

  4. F6bbe1b73a47307bf37d49741287bde7?d=mm

    Tyrathect

    Aug 25, 2016 02:57

    still happening frequently in 5

  5. 15a94da42ca8c5cddc370557eca9f74a?d=mm

    senchov

    Jul 13, 2016 16:04

    Not Working on Unity 5.2.2, please fix it

  6. A5e5ad1906919bf3228a3458ec4fd700?d=mm

    rsodre

    Apr 20, 2015 02:38

    Still happening on Mac OS X 10.9.5, Unity 3D Pro 4.6.3

  7. Fc043cf46dacb94ddc30fed251b48446?d=mm

    akenaton

    Mar 23, 2015 16:16

    Still Not Working on Unity 4.3.f1with Monodevelop 4.0.1 on yosemite 10.10.2
    Impossible to attach unity Editor Debugger
    It freezes
    Cannot Cancel too
    Need to kill Monodevelop

  8. 2c05a461f1bdf69fc664352628755e73?d=mm

    _Radagan

    Mar 03, 2015 07:26

    This is not fixed... it's back in Unity 5 RC3 on Yosemite. I can't debug with Monodevelop at all. Freezes on attach every time.

  9. 8ff48cbb22c5619d4875576f8683dcfa?d=mm

    WarbladerToo

    Dec 19, 2014 01:21

    Im on a Mac using Yosemite 10.10 and if restart the machine I can run Unity and start up monodevelop and do debugging just fine. But if Unity (I'm on 4.61 patch 1) crashes and I restarts it it would make monodevelop crash/hang every time I try to attach to the unity process. I have to restart the Mac to make it work again. This is really bad as there is a lot of stuff I have running that needs restarting.

    I also use Sublime Text for editing the source files. it about 1.000.000 times better then monodevelop and its super fast.

  10. Ff6e9b227d365b1758bffff546d6346d?d=mm

    seaders

    Dec 03, 2014 17:00

    This was definitely *not* fixed in 4.5, and it is still present in the 4.6.0f3 as well.

    Who decides this is resolved, and stays as such when the community all state the bug is still there? Do we have to create a new bug tracking issues?

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.