Search Issue Tracker

Fixed in 2018.1.X

Fixed in 5.6.X, 2017.1.X, 2017.2.X, 2017.3.X, 2017.4.X

Votes

147

Found in

2017.1.0b8

Issue ID

921915

Regression

Yes

"Assertion failed: TLS Allocator ALLOC_TEMP_THREAD..." error is shown after building the project for iOS'

Themes

-

To reproduce:

1. Create a new project
2. Build it for iOS
3. Observe the console after the build has finished

Expected: no assertion errors are shown after building the project for iOS

Reproduced in 5.6.0a2, 5.6.1p4, 2017.1.0b8, 2017.2.0a4
Did not reproduced in 5.5.4f1, 5.6.0a1
Regression introduced in 5.6.0a2
Not reproducible in 2017.3.0a3

Comments (110)

  1. Ea51786374a599b00d8238e0df3e2bac?d=mm

    O1lec1

    Mar 15, 2021 14:31

    Still broken.

  2. 5505f9574572edd1103f430cad8631fe?d=mm

    Fillmore

    Jan 14, 2021 23:10

    Still happens on 2020.2.1f1

    Allocation of 80 bytes at 0x13eed34f0
    TLS Allocator ALLOC_TEMP_THREAD, underlying allocator ALLOC_TEMP_THREAD has unfreed allocations, size 80
    Internal: Stack allocator ALLOC_TEMP_THREAD has unfreed allocations, size 80
    To Debug, enable the define: DEBUG_STACK_LEAK in StackAllocator.h. This will output the callstacks of the leaked allocations

  3. 09013df40f7479ebc65a28764e0c8df9?d=mm

    unity_-czh6Add1XgRzg

    Oct 13, 2020 10:12

    Just got this bug after creating a new Unity 2019.4 project, importing the MRTK v2.4, deleting SampleScene and creating a blank empty new scene

  4. 09013df40f7479ebc65a28764e0c8df9?d=mm

    unity_-czh6Add1XgRzg

    Oct 13, 2020 10:12

    Just got this bug after creating a new Unity 2019.4 project, importing the MRTK v2.4, deleting SampleScene and creating a blank empty new scene

  5. D1ec1b8aa037de3dac7ceb09f7a60d69?d=mm

    dgoodman-icf

    Aug 22, 2020 00:47

    Still happens in 2020.1.2

  6. 6b4e9adc154b7221b03238586355dcf9?d=mm

    Barritico

    Jun 12, 2020 20:57

    2019.4.0f1... same

  7. 29105ec7744d0fd13d15d07fcbd76335?d=mm

    AhmadMcreator

    May 30, 2020 03:28

    Been trying to solve this for a couple of days now using peoples "fixes" but none of them work! I'm on 2019.3.4f1

  8. 3b07fb9a298471a9b1209c44589bfde7?d=mm

    a85jafari

    May 07, 2020 17:51

    2019.3.0f6

  9. 3b07fb9a298471a9b1209c44589bfde7?d=mm

    a85jafari

    May 07, 2020 17:50

    Happend to me 2019.0f6

  10. A1b424ad89a5b9cd3c2015345f993af8?d=mm

    ASIM-SENYUVA

    Apr 26, 2020 14:10

    Just happened in 2019.3.4f1

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.