Search Issue Tracker

Not Reproducible

Votes

1

Found in

5.0.1f1

Issue ID

690090

Regression

No

The file 'MemoryStream' is corrupted! Remove it and launch unity again! [Position out of bounds

Assets Management

-

This issue has no description.

Comments (70)

  1. 1c74c7a3b4d6872093d638674d404cef?d=mm

    unity_wNxzpZ76EgBx6A

    Dec 01, 2020 15:29

    Solved (At least for me the last two times this issue popped up)

    Simply open up a different Unity project from Unity Hub, then try reopen your project that has this issue. This has solved the issue for me each time.

  2. 06b6bd6b4d0d14ac95d31b54e5832802?d=mm

    PeterVoss

    Nov 19, 2020 16:35

    I had this on Mac Unity version 2020.1.4f1 on all of my projects. I have installed 2020.1.13f1 and migrated the projects over and everything was working fine again. Today I have the same problem with 2020.1.13f1 (without making any changes to the projects) and I had to switch to 2020.1.14f1. Now it works again. To me it seems that reinstalling Unity helps, but I have no clue what is breaking it quite often. It is getting quite annoying and even though it is hard to reproduce it seems that there a bunch of other people that have this problem.

  3. 4e5f3f0c9b5c9f437024fcadd1687c30?d=mm

    mrsorry78

    Oct 22, 2020 11:00

    Unity 2020.1.9f1

    1) Open a project
    2) Import fbx file
    3) Close a project
    4) Reopen -> Looooong importing of fbx file -> Crash

  4. Bd2731547783ea1e603d0d878dd318e8?d=mm

    aganm

    Apr 13, 2020 14:41

    I just had this error in Unity 2019.3.3

  5. Af818a0d043aa92bd9c494e198919d1f?d=mm

    JamesStallings

    Oct 23, 2018 11:40

    I have the issue on 2017.2.4.f1. I am not developing for a device. Remote was never configured as anything other than 'none'.

    If I remove the project 'Library' folder per the circulated recipe for relief, I get rid of the MemoryStream
    issue, but a new one takes it's place; any thing selected in the hierarchy will have all it's components display a message 'Nothing Selected' in the inspector pane.

    It's a vicious cycle; if I do the things to address that problem, the MemoryStream problem reappears.

    Any suggestions or further information about this problem would be greatly appreciated.

    TIA

    James

  6. Dc33dc613eeb22c1fbeb69b8d52ae94c?d=mm

    hameed-ullah-jan

    Jul 05, 2018 17:26

    Caused due to Less space in the disk, after deleting some files from disk solved the issue.

  7. E3dbfd4ea21d14dc939db9b6ffc3e465?d=mm

    forestrf

    Aug 24, 2017 14:41

    I just had this problem:

    The file 'MemoryStream' is corrupted! Remove it and launch unity again!
    [Position out of bounds!]

    (Filename: C:\buildslave\unity\build\Runtime/Serialize/SerializationCaching/CachedReader.cpp Line: 215)

  8. 0af02c365cfa13cf47532cd3629d16ef?d=mm

    Faloon

    Mar 26, 2017 01:19

    For me it helped to disconnect the iphone from the usb port and to then run the code in the editor once. after that I saved the scene and project and later reconnected the phone and started unity remote again and all went well.

  9. A8be9f7e3404bd007c74ca4e41545f43?d=mm

    Lloyd_RedironLabs

    Dec 02, 2016 17:37

    Same error here. 5.5.0f3 as well. And I'm not even using the Unity remote stuff

  10. F5669db31a609dc6b28a9c49358915d0?d=mm

    yummybrainz

    Nov 30, 2016 20:53

    Just downloaded Unity 5.5.0f3 and getting this error.. If I create a new blank project I can open the editor but opening any other project crashes.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.