Search Issue Tracker

Fixed

Votes

89

Found in

4.3.0b4

Issue ID

567130

Regression

No

Scrolling doesn't work with Apple Mighy Mouse A1152

CodeEditors

-

Steps to reproduce :

- have an Apple Mighty Mouse A1152 connected
- open a longer script in Mono Develop
- try to scroll with the mouse and notice it doesn't work

Comments (64)

  1. B78b5e963ce9f6413c46685a94ee2eb5?d=mm

    cloveky

    May 13, 2015 02:05

    Upgraded to Unity 4.6.5f1 on Yosemite 10.10.3 A1152 Mighty Mouse finally get the scrolling back!

  2. 6cf884289b30bf5f6adaf9a54ff0361e?d=mm

    Arctous

    Mar 02, 2015 03:43

    Is there any news on when this will be fixed? Or, in what version the fix will be released?

  3. 1218bb2f752043d4f5a598371cd5d41d?d=mm

    toneguy

    Mar 01, 2015 20:59

    this is not resolved, or fixed

  4. 2fbfb35f1ba1c6e720bfb3ea76e3a02e?d=mm

    justinluk

    Feb 05, 2015 23:21

    My issues with the Logitech Control Center on OSX and not being able to scroll in Monodevelop have been solved. Works now. Thanks!

  5. Cfbe34c57475c74177cb04975e950ccf?d=mm

    bluescrn

    Feb 02, 2015 14:34

    Definitely still not fixed :(

    Using 4.6.2, with an Apple A1152 mouse (Mac Mini, Yosemite)

  6. 60a779162aafadf6f7269c082abfc1ed?d=mm

    jaz78

    Jan 26, 2015 10:21

    After installing Patch 4.6.1p5 i noticed the issue no longer occurred on my Mac with a Logitech Marathon Mouse m705 and Logitech Control Center installed.
    There was no mention in the release notes about this fix so i can't confirm if just coincidence or not.

  7. 5c937895353403fe4b4adfd8b93b23d4?d=mm

    graycode

    Jan 24, 2015 15:31

    Can confirm this issue is NOT FIXED in 4.6.1 - how do we update the status?

    Also, Konkybean, another unfortunate reason we kinda have to use MonoDevelop (instead of Xamarin, etc.) is so that we can use runtime debugging and step through the code. People have gotten it to work for a build or two with other editors on Mac, but it's a headache and a moving target.

  8. Ed1dfa9702335a519ddedf360ca3efbb?d=mm

    KonkyBean

    Jan 19, 2015 06:13

    Oh, just realised Xamarin Studio doesn't have the specific Unity coding "hints" like the built-in Monodevelop does, so it's not the perfect solution. However, I'd rather this than the scroll wheel not working at all.

    It'd be nice if Unity fixes the issue rather than marking it as "fixed".

  9. Ed1dfa9702335a519ddedf360ca3efbb?d=mm

    KonkyBean

    Jan 19, 2015 05:41

    Hi Guys,

    I'm new to Unity (downloaded it ages ago but only now working through the tutorials), and this issue was driving me ABSOLUTELY BONKERS as well, but I've found a solution which has worked for me so far:

    1. Go to http://www.monodevelop.com/download/
    2. Download and install Xamarin Studio
    3. In Unity, go to "Unity-->Preferences-->External Tools"
    4. In the "External Script Editor" field, browse and select "Xamarin Studio"

    Now Unity will use Xamarin Studio as the default script editor, which is pretty much the same as Monodevelop (maybe even more powerful but I have no idea). You can probably use other editors like TextWrangler too.

    Anyway, like I said I've only been doing this for a few days now, and have had no issues since switching to Xamarin Studio.

    Hope that helps you guys.

  10. B9944ebfc5acd078c8358b27dde31cec?d=mm

    havoc74

    Jan 15, 2015 18:00

    Hi, I am still having this issue.

    MacBook Air (13-inch, Mid 2013)
    OSX Yosemite 10.10.1
    Unity 4.6.1f1
    MonoDevelop 4.0.1
    Logitech m510

    I cannot scroll an opened script unless I first scroll with the touchpad down a little. The m510 scrolls fine after that, unless I scroll up to the top of the script, then m510 scrolling does not work. I tried page down as well and it does not work. Only when I scroll down a bit using the built-in touch pad.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.