Search Issue Tracker

Fixed

Votes

89

Found in

4.3.0b4

Issue ID

567130

Regression

No

Scrolling doesn't work with Apple Mighy Mouse A1152

CodeEditors

-

Steps to reproduce :

- have an Apple Mighty Mouse A1152 connected
- open a longer script in Mono Develop
- try to scroll with the mouse and notice it doesn't work

Comments (64)

  1. 60a779162aafadf6f7269c082abfc1ed?d=mm

    jaz78

    Jan 11, 2015 18:11

    Status: Fixed - What does this mean exactly?
    Is the fix coming in a later patch?

    I have 4.6.1p3 and still have the issue.

  2. 4d5e9da3eaacf24f75c5e453baf1e45d?d=mm

    spartan029

    Jan 11, 2015 13:11

    I'm also unable to scroll in monodevelop 4.0.1 with my Logitech T630 :(
    I can scroll in every other program on my mac.

    Mac OSX 10.10.1
    MonoDevelop 4.0.1
    Unity 4.6.1f1

  3. B0c5bd035c2135782d7d9ea4f3f74a8b?d=mm

    HauntedHotPocket

    Dec 30, 2014 08:01

    Logitech Performance MX. Scrolls in all other windows/apps other than Monodevelop 4.0.1

  4. Dd01d8196f12fb26ca6995d848321c2d?d=mm

    BigToe

    Dec 23, 2014 23:25

    Removing the Logitech Control Center and replacing with USB Overdrive worked for me. This has been an incredibly stupid waste of 40 minutes.

  5. Acfd3c84c6a0d327dea472200135f7f1?d=mm

    Spatanz

    Dec 23, 2014 05:05

    Apple Mighty Mouse scrolling does't work in MonoDevelop 4.x

    My solution was copy the old version MonoDevelop (Mine one is 2.8.2) from older Unity folder, and replace with the MonoDevelop 4.x

  6. 0378a074f560eeb25252589e31cfe087?d=mm

    draber

    Dec 12, 2014 18:28

    Wanted to post a fix I found. If any of you are using the Logitech Control Center, uninstall it and find an alternative program. I use USB Overdrive and SmoothMouse to control my mouse stuff.

    I had no problems with a different mouse until installing the control center, which I had to do in order to pair an M705 with a logitech receiver. I found another thread where a user reported uninstalling the LCC fixes the scroll problem.

    You can find the Uninstaller in Applications -> Utilities.

  7. 62acdc69fb1319c692519d3d5e8994bb?d=mm

    argc_argv

    Dec 06, 2014 17:14

    Am using a rollermouse red. CAN scroll in unity, CAN NOT scroll in monodevelop.

  8. 5bc8c3f5c61bee8da6228b1ad47fdb1a?d=mm

    Sylafrs

    Dec 04, 2014 14:44

    OS X 10.9.5
    Logitech B110

    The scroll worked but the middle button wasn't working well (launching mission control) so I've dowloaded Logitech control panel, changed the middle button behaviour. It disabled scroll on Monodevelop only. Can't figure out how to make it work again.

    I will use Xamarin while the bug remains.

  9. F2a93fde1fc3d90c9458cb1dc8d46052?d=mm

    jcdsr3

    Nov 28, 2014 15:32

    No fixed, i just update to unity 4.6 and still the same, I also delete the library preferences on my Mac and nothing?

  10. E2b879f6a86f38f0f39a7cb51d45fa4d?d=mm

    MattijsKneppers

    Oct 20, 2014 08:42

    Still not fixed....

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.