Search Issue Tracker

Fixed

Votes

89

Found in

4.3.0b4

Issue ID

567130

Regression

No

Scrolling doesn't work with Apple Mighy Mouse A1152

CodeEditors

-

Steps to reproduce :

- have an Apple Mighty Mouse A1152 connected
- open a longer script in Mono Develop
- try to scroll with the mouse and notice it doesn't work

Comments (64)

  1. D9f1c1876d0e2f36a4f91fb169d9c9e8?d=mm

    scatterbraincc

    May 29, 2014 15:48

    Logitech M510

  2. Db39b8443f5d880c3ccb5d2878116d53?d=mm

    Rafael Costa

    May 15, 2014 13:54

    Same problem: Logitech Performance MX

  3. 05570054381d49ce3824125f20f81c7f?d=mm

    eobet

    May 06, 2014 07:12

    My scrolling worked immediately after install, but then stopped working after a few hours and now I have no idea how to get it back (tried restart already).

    I have the old Apple wired mouse.

  4. 447ec408fcfa6e5a1de0159e95eeb192?d=mm

    Andy Block

    Apr 08, 2014 12:37

    I had this problem with my Logitech M705. It seems that uninstalling the Logitech Control Center software fixes the issue (but annoyingly also disables much of the useful additional functionality on the mouse, such as the extra buttons). Still, for me that is better than no scrolling in MonoDevelop; hope it is helpful for somebody else.

  5. 9d7c9c98bda90420ab45097088cd95c3?d=mm

    Robert Castle

    Apr 06, 2014 14:38

    This bug has made coding in Monodevelop on the Mac incredibly infuriating. I have a logitech performance MX mouse and a wacom bamboo tablet. Neither allow me to scroll. Remoting in using a laptop allows me to scroll using a trackpad, but that is not a workable solution.

  6. 28107ab6b78806a4df1fa7c6d09a1073?d=mm

    beasthacker

    Mar 26, 2014 16:27

    Same issue here. Using a logitech M705. The "workaround" also works meaning I can scroll if holding down middle mouse albeit very slowly.

  7. C8ddfc788c821ef163bf449fbfa8cc5d?d=mm

    Ampharel

    Feb 26, 2014 18:35

    I have the same problems, but I have a very annoying workaround. Hope it helps you guys too.

    I seem to be able to scroll, as long as I keep the middle mouse button pressed.
    Hopefully this gives someone a clue to the solution ^^

  8. Cf2fa35b125b9b95044fe28e98863ca0?d=mm

    RyanZimmerman87

    Feb 25, 2014 03:21

    Yeah I've had all kinds of trouble with mouse scrolling on my macbook pro, needs to be fixed. I use a Logitech M510.

  9. B1d35abe03cacfc40be1ba7a713c1691?d=mm

    Alf203

    Feb 14, 2014 16:46

    Was fixed in Xamarin many many months, hoping that Unity upgrades it soon its driving me crazy. I have a logitech MX performance.

  10. A0c146cfea3b1c2b8547488de01d48c6?d=mm

    tomshreds

    Feb 08, 2014 22:49

    This is INCREDIBLY annoying as all my mices are Logitech Performance MX, I love those and I cannot use them on Unity's new IDE except if I use Xamarin (what's the new editor is now built from) directly it works. Please fix this, I've been running Visual Studio in a VM for months now :(

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.