Search Issue Tracker

Fixed in 5.0

Votes

55

Found in

4.3.0f4

Issue ID

575602

Regression

Yes

CMD+A does not select text but repeats some of the actions made recently

CodeEditors

-

To reproduce:
1. Open any project that contains a script
2. Double click on a script so it opens in MonoDevelop
3. Press CMD+A
4. Notice, that all text was selected
5. Click Build -> Build All
6. Wait for the project to be built
7. Press CMD+A again
8. Notice that it does not select all text but instead builds the project
9. Click Run -> New Breakpoint -> OK
10. Press CMD+A
11. Notice that it adds/removes breakpoints from the line where the cursor is.

Comments (42)

  1. 124981dedb855069dabef0673e0988ef?d=mm

    cesarpo

    Aug 07, 2014 22:23

    When this is going to be fixed?

    Seems like `Cmd + A` tries to execute the las command, instead of selecting text, super annoying bug!

  2. 66d977dbbcb7054ea68da2950271c3cd?d=mm

    carsonlee

    Jul 05, 2014 23:26

    What's worse than a common shortcut not doing what it is supposed to? A common shortcut that pretty much does random stuff depending on the time of day you hit it.. Yeesh!

  3. C364bb5dceae6db8cb22d210a1f6f78b?d=mm

    mcarriere

    Jun 22, 2014 21:14

    This seemingly still exists on 4.5.1f3.

  4. 6c2e3dd42a6459df1606e7a55dffe8fe?d=mm

    bunnyhero

    Jun 07, 2014 06:05

    so it's not just me! so baffled when trying to hit cmd-A, LIKE IT SAYS IN THE MENU, and something completely different happens.

  5. 88f4cf4ac5474f96d1eeab77f87ac1be?d=mm

    jrhee

    Jun 06, 2014 14:40

    Incredibly disruptive to our workflow! Can't be worked around by updating key bindings.

  6. 5142e3fa7a2e414d4ffefe8d5115782d?d=mm

    drawcode

    Apr 20, 2014 18:01

    This is one of those soul crushing flow state breaking bugs. It is like being at the theatre and the projector breaks or someone spills a drink on you, takes you right out of the moment.

    The glitchy renderings on folding, updates on the code can easily be solved by a CMD + A but when your code gets all render mangled then you hit CMD + A to clear it, then the app closes, it is time for a snack.

  7. 517e19d07eeea58088425e23574c184c?d=mm

    eugenejo

    Feb 26, 2014 19:36

    FIX IT!

  8. F8954a48a61cfa164201352866d33270?d=mm

    iEpic

    Feb 25, 2014 00:32

    If you are using mac, make a keyboard shortcut for Select All under the system preferences<keyboard

    Select the mlnodevelop app and type Select All where it says menu title and do the keyboard shortcut you want for it.

  9. F93187ac5850bdf6e995a313926a3cd2?d=mm

    tealm

    Feb 04, 2014 09:47

    CMD+A should select all content yes, as specified in the keyboard shortcuts. This bug is horrible, and I hope Unity can fix it soon.

  10. 5f03a6048af85a2a41e21fd0d2e8ea3d?d=mm

    Essential

    Feb 03, 2014 18:11

    I've got this issue… it minimizes my Monodevelop window when pressing CMD+A. So frustrating!

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.