Search Issue Tracker

Fixed in 5.0.X



Found in


Issue ID




CMD+A does not select text but repeats some of the actions made recently



To reproduce:
1. Open any project that contains a script
2. Double click on a script so it opens in MonoDevelop
3. Press CMD+A
4. Notice, that all text was selected
5. Click Build -> Build All
6. Wait for the project to be built
7. Press CMD+A again
8. Notice that it does not select all text but instead builds the project
9. Click Run -> New Breakpoint -> OK
10. Press CMD+A
11. Notice that it adds/removes breakpoints from the line where the cursor is.

Comments (42)

  1. domiii

    Feb 08, 2016 07:08

    Any ETA on the MonoDevelop upgrade?

    Seems somewhat overdue, considering that its currently shipped with 4.0.1.

  2. lukaszunity

    Jul 29, 2015 10:12

    This issue will be fixed once we upgrade to MonoDevelop 5.9

    Here are some details on how to use Xamarin Studio 5.9 with Unity today.

  3. mostafa_berg

    Jul 29, 2015 07:38

    Here is what i've done to get this working for me without any 3rd party tools (note that it's already marked as will be fixed in future release), if you still have the problem try the following:

    I'm doing this on a Mac
    1-Open up mono preferences (Cmd+,)
    2-Go to Environment->Key bindings
    3-Delete all bindings
    4-Save and restart mono
    5-Now Pressing Cmd+A should work again, but all other shortcuts won't
    6-Go back to Key Environment->Key bindings
    7-Select "Default" Scheme
    8-Depending on your version it might show a conflict, simply remove any conflicting bindings
    9-Note that after fixing conflicts you will be back on the "custom" scheme, but with everything in place

    After that the problem was gone , done on both my macs
    I'm not sure if removing all the bindings is the key, but i tried it while attempting to fix to see what's really triggering if we had no bindings, it seemed to me that everytime i deleted a binding, cmd+a triggers the next binding on the list of bindings, when all are gone, it triggers it's own job, select all..

    good luck !

  4. aaronransley

    Jul 28, 2015 16:37

    Also having this problem. Pretty crappy considering it's been a known issue for nearly 3 years.

  5. didito

    May 27, 2015 13:31

    still happening in 4.6.5f1 / MD 4.0.1

  6. charliehelman

    May 12, 2015 21:40

    Happening to me. For me, it pulls up Author Preferences. It only starts happening after I've opened Monodevlop's preferences window. Need to restart Monodevelop to fix the issue.


  7. dominuselectus

    Apr 30, 2015 16:44

    Additional information to this bug:
    The bug is not bound to the 'Select All' function. It is bound to the specific action of pressing 'command' and 'a' at the same time.

    Workaround with Keyboard Maestro:
    Change the shortcut of 'Select All' to something arbitrary such as 'ctrl+a'.
    When inside mono, have 'command+a' send 'ctrl+a' instead of 'command+a'

  8. nonselection

    Apr 08, 2015 13:57

    Yeah, still not fixed in Unity 5.0.0p3 aka the latest patch release.

  9. SmilingRob

    Mar 23, 2015 03:57

    Confirming not fixed in Unity 5.0.0f4

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.