Search Issue Tracker

Fixed in 5.0

Votes

55

Found in

4.3.0f4

Issue ID

575602

Regression

Yes

CMD+A does not select text but repeats some of the actions made recently

CodeEditors

-

To reproduce:
1. Open any project that contains a script
2. Double click on a script so it opens in MonoDevelop
3. Press CMD+A
4. Notice, that all text was selected
5. Click Build -> Build All
6. Wait for the project to be built
7. Press CMD+A again
8. Notice that it does not select all text but instead builds the project
9. Click Run -> New Breakpoint -> OK
10. Press CMD+A
11. Notice that it adds/removes breakpoints from the line where the cursor is.

Comments (42)

  1. 1ed7298c1e3bd188e0d4d0bc021187e0?d=mm

    zephlabs

    Mar 07, 2015 10:58

    STILL Not Resolved. CMD+A still does random things for me even in Unity 5.0.0f4. Currently it opens my web browser to look up whatever the caret is on in the unity API (useful, but not when i'm trying to select all).

  2. 74c44119b3b78f0dbdeb3986e3ea0386?d=mm

    proskub

    Mar 05, 2015 09:44

    Despite being listed as fixed on the release notes for 5.0 (http://unity3d.com/unity/whats-new/unity-5.0), this issue is still occurring. Even occurs on a fresh install of Monodevelop – tried completely removing the preferences and reinstalling but the problem is still EASILY reproducible.

    Please for the love of jeebus provide a fix for this bug, which has been around for at least a year through two major version cycles of Unity and prevents us from using a ubiquitous and fundamental keyboard shortcut. It's depressing that our default bundled IDE is broken like this without any other comparably featured alternative on Mac (who would want to develop on Windows... yuck). I will gladly donate my time as a developer, for FREE, if that means this issue will finally be prioritized to be resolved. I'm thankful for all your hard work and don't hate you guys, I just hate this.

  3. A5284d6da41699ed9e9d5f70c9f16301?d=mm

    Blake Triana

    Feb 06, 2015 19:40

    Bug still happening on Mono v 4.0.1 with Unity 5 beta 22.

    Had it zap a few hours worth of code when pressing CMD-A during a Find/Replace operation. Can't really use MonoDevelop anymore.

  4. 77f05875baea9117bd7966dd6d12b2fc?d=mm

    PearShapedCode

    Jan 04, 2015 21:23

    Only noticed this recently because I've been reimporting old code into new files, having to do manual menu dropdowns to select all is a royal PITA, CMD+A randomly remaps to text search, open project file, rebuild and a few others. Restarting makes it work for a few minutes and then it randomises again :-(

    Unity 4.6.1f1 Here with MonoDevelop 4.0.1 (Build date: 2014-11-17 10:29:13+0000) on 10.10.1

  5. 5f03a6048af85a2a41e21fd0d2e8ea3d?d=mm

    Essential

    Dec 16, 2014 16:49

    Happening to me in 4.6.0f3

    Cmd+A actually causes a build, even though the key bindings are set up correctly.

  6. 8991633dba85c44449a724678e5dfe32?d=mm

    Doomlaser

    Dec 14, 2014 06:08

    This issue is still happening in the MonoDevelop shipped yesterday in Unity 4.6.1

    After a certain amount of time, hitting CMD-A performs a random action. Right now for me, it _minimizes MonoDevelop.app_

    This is exceedingly frustrating. The bug tracker says this has been resolved for a future version for . What future version? Please, this is maddening. It's been over a year since this bug was reported. What's going on?

  7. Da9e8cbb7d8e3be5c03b8d47911d2822?d=mm

    Matthew Schell

    Dec 04, 2014 17:09

    Note this issue continues in 4.01 which ships w/ 5b15.

  8. Dd43f519d40c53682af5a5ee8b56e21c?d=mm

    elias.ku

    Nov 28, 2014 19:35

    In 4.5.5p2 cmd+a do "find.." feature instead of "select all". This is so annoying. Regression?

  9. Dd43f519d40c53682af5a5ee8b56e21c?d=mm

    elias.ku

    Nov 28, 2014 19:35

    In 4.5.5p2 cmd+a do "find.." feature instead of "select all". This is so annoying. Regression?

  10. Ac934ab75e5e768bbe210abdf201acae?d=mm

    SpatulaHammer

    Nov 26, 2014 22:45

    Affecting me, also. Just upgraded to Unity 4.6. CMD+A will now periodically switch to building the project, rather than selecting all text.

    from my MonoDevelop 'about':

    MonoDevelop-Unity
    Version 4.0.1

    Runtime:
    Mono 2.10.11 (mono-2-10/2baeee2 Wed Jan 16 16:40:16 EST 2013)
    GTK 2.24.14
    GTK# (2.12.0.0)
    Package version: 210110000

    Build Information
    Git revision: Release ID:
    a8b105ab0c60bf756c34c19d917430c690db4f46
    Build date: 2014-11-17 10:29:13+0000

    Operating System
    Mac OS X 10.9.5
    Darwin HOSTNAME 13.4.0 Darwin Kernel Version 13.4.0
    Sun Aug 17 19:50:11 PDT 2014
    root:xnu-2422.115.4~1/RELEASE_X86_64 x86_64

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.