Search Issue Tracker

Fixed in 2018.3

Fixed in 5.5, 5.6, 2017.1, 2017.2, 2018.1, 2018.2

Votes

334

Found in

5.6.0b5

2017.1.0f3

Issue ID

873467

Regression

Yes

Unity throws out Fatal Error: Callback registration failed kMaxCallback

Themes

-

Unity throws out Fatal Error: "Callback registration failed kMaxCallback" after working with the project for 30 minutes or more. It appears randomly.

Steps:
1. Actively use Unity for more than 30 minutes

Actual: Unity continues to work
Result: Unity crashes with Fatal Error.

Reproducible with: 2017.1.4f1, 2017.2.3p1, 2017.4.4f1, 2018.1.3f1, 2018.2.0b6

Note:
Reproduced on macOS, Windows, Linux.
Bug Report window does not appear.
Scene files are not restored after reopening Unity so all not saved Scenes are lost.

  1. Response avatar

    karl_jones

    Jan 04, 2019

    Please file a new bug report If you are still encountering this problem. The error message is a symptom and can be caused by many different areas. The area for this bug has been fixed.

Comments (202)

  1. B1a4a915401dc1536342a1ff5b9f2118?d=mm

    ArtyomIsFlash

    Jul 26, 2017 19:29

    same error when entering play mode when you did it like 5-6 times. 2017.1.0f3, windows 10. freaks me out every time it happens

  2. 98c2c9682045df04a347b83e33db2248?d=mm

    Hadrien

    Jul 26, 2017 13:33

    Same problem here, this bug came out for the first time after I have update Unity from Unity5.6.2 to Unity 2017.1.0f3 personal.
    It crash randomly, sometimes I can work for 3 hours without crash and sometimes for 30 minutes.

  3. 837ebb49702c6967e0bb2802eb6664de?d=mm

    Sudarmin-Then

    Jul 26, 2017 12:20

    Yes, still happening in Unity 2017.1.0f3, I'm using Windows 10, happens everyday but very random, usually after updating a .cs file and then going back to Unity Editor, sometimes it happened when I just kept open the editor for a few hours while I'm doing something else on the computer, when I came back to the editor it will crash with "Callback registration failed kMaxCallback"

  4. 86f81d7d9799b656f41312c38a561d2a?d=mm

    FirstLightStudios

    Jul 26, 2017 02:00

    Unity 2017.1.0f3 Personal - PC Windows 10 Home - Happening fairly frequently

  5. 45898b281947206152e91cdbd9ebcb40?d=mm

    yigitdream

    Jul 25, 2017 19:55

    After the OS X 10.12.6 update all the versions give an error when unity unfocused in play mode. (5.6.1.p1 ,5.6.2p4 ,2017.1.0p1 )

  6. 9396937821c4a3b8038ea664249e15a0?d=mm

    mrm83

    Jul 25, 2017 15:11

    Mac OSX, Unity 2017 1.01f3, crashes every 30 mins.

  7. Aa1448d9053676715bc93842e0cd6706?d=mm

    Feelnside

    Jul 25, 2017 14:27

    The same issue for me was faced in Unity 2017.1.0f3 on Mac OS 10.12.6. Previously it was worked perfectly in Unity 5.6. It's very bad stuff and as far as I can see it's often reproducible after clicking the "Play" button in editor. You just trying to check some changes and the issue appears. As result all changed data is missed...

  8. B72077b6eeca65a157def1c63a9868bd?d=mm

    zzgrzyt

    Jul 25, 2017 11:02

    Crash log from 2017.1.0f3 when this error happened but the popup did not even show up and Unity just crashed: https://pastebin.com/Ciy211sy

    It happened after I moved two scripts between folders in the Project window in Unity.

  9. 12cbbafc504c07fe7dfdd7e004ce1e93?d=mm

    hwizard

    Jul 25, 2017 07:39

    2017.1.0f3 personal :( frustrating

  10. 33f90bebbd6fd92b27a34291f9bc7789?d=mm

    GorrionMW

    Jul 25, 2017 07:36

    Happens to me quite often, tho sometimes there's not even any error message. Wonder if its even the same issue. Seems to happen randomly. There have been a few days with no crashes but many days when they would happen very frequently. Noticed that many of the crashes occurred right after changing a file in Visual Studio, then immediately pressing Play in the editor.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.