Search Issue Tracker

Fixed in 2019.3.X

Fixed in 2019.4.X



Found in



Issue ID




[Package Manager] User Not Logged In error appears if the editor is launched with the My Assets tab open



If you launch the editor with the My Assets section of the Package Manager open, you'll receive the following log in the console once the asset list has been refreshed.

[PackageManager] Error User not logged in

The Package Manager will also display an error saying "Error fetching packages, see console". Manually refreshing the package list at this point will NOT clear the error, even though the package list refreshes correctly.

I cannot reproduce this on 2020.1, so looks 2019.3 specific.

1. Open Unity and create a new project
2. Ensure that the Package Manager window is open and is set to the My Assets Tab
3. Close the editor
4. Open the editor again and open the previous project
5. When the editor opens, wait for the Package Manager to refresh

Expected Result:
The Package Manager completes the refresh process with no errors.

Actual Result:
The Package Manager displays a User Not Logged In error even though the packages are refreshed correctly.

Tested on Windows 10.

Reproduced on 2019.3.0f5, 2019.3.0b2

Cannot reproduce on 2020.1.0a19, 2019.3.0a12

Blocked from testing on 2019.3.0b1

  1. Resolution Note (fix version 2019.3):

    Verified fixed on

    Version 2019.4.6f1 (a7aea80e3716) Personal
    Tue, 21 Jul 2020 18:49:45 GMT
    Branch: 2019.4/staging

  2. Resolution Note (fix version 2019.4):

    Verified in

    Version 2019.4.7f1 (e992b1a16e65) Personal
    Wed, 29 Jul 2020 13:51:28 GMT
    Branch: 2019.4/staging

Comments (39)

  1. MacFig

    Sep 27, 2022 10:59


  2. guneyozsan

    Sep 11, 2022 14:28

    In my case Unity Hub login had no effect on Unity Package Manager. I had to do 'Window/Asset Store', and click "Sign In" on top-left corner in Asset Store window (It's an editor UI button, not in Asset Store web view). Then open "Package Manager/My Assets" and click "Refresh".

  3. Andy-Block

    Sep 11, 2022 07:40

    I got this message on 2021.3.9f1 - but eventually noticed I was in play mode, and discovered that just stopping the game seemed to fix the issue.

  4. idavida

    Aug 05, 2022 21:24

    This is not fixed, but this comment works as a work around:
    CONMANDOUGLASAPR 30, 2021 14:26

  5. chipo117

    May 23, 2022 17:18

    I got this error with Unity 2020.3.0f1.
    The problem was solved using the technique from CONMANDOUGLAS below.
    Thank you!

  6. Geoffc

    May 12, 2022 15:02

    I am getting this error with Unity 2021.3.2f1

  7. Conmandouglas

    Apr 30, 2021 14:26

    SOLUTION: I found a solution to the problem listed. Follow the steps below carefully

    1. Close out of Unity project
    2. Open Unity Hub, open Unity Hub settings, click 'Advanced', then click dropdown and select Production
    3. Restart Unity Hub
    4. Open Unity Hub and log out of account
    5. Log back in to your account
    6. Restart Unity Hub
    7. Open your project
    8. Open package manager (Window > Package Manager)

  8. giantguppy

    Mar 29, 2021 16:07

    Maybe my issue is different, but hopefully this will help somebody. In my case, on macOS Catalina, I was unable to install Unity Editor via Unity Hub. But in order to use the Package Manager to install an asset I did...
    1. run Unity Hub
    2. add/locate my editor
    3. sign in
    4. re-open my project from the hub

    Then Package Manager was signed in and worked. It seems really strange to allow installation of Unity separate from the hub with apparently no way to sign into package management--no way to import newly purchased assets--without the hub.

  9. giantguppy

    Mar 29, 2021 15:49

    But in my case assets are not refreshed correctly. Refresh fails and says "[Package Manager Window] Error while getting product update details: User is not logged in or user status invalid.
    UnityEditor.GenericMenu:CatchMenu (object,string[],int) (at /Users/bokken/buildslave/unity/build/Editor/Mono/GUI/GenericMenu.cs:126)"

  10. giantguppy

    Mar 29, 2021 15:48

    How is this fixed? I'm getting it on 2020.3.0. Is it possible to sign into asset management from the editor?

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.