Search Issue Tracker

Fixed in Unity 5.4.3

Votes

19

Found in

5.4.0b22

Issue ID

807375

Regression

Yes

Icon quality decreases after building

Deployment Management

-

-

Priority: 2Necessary for shipping a final release

-

Severity: 3Workaround is possible

Steps to reproduce:
1) Open the project attached by me (iconTest.zip).
2) Build the project for any platform (Standalone, Android, iOS).
3) Open the build as an archive (view its contents).
4) Locate the icon file of the build.

- Compare the icon from the build with the icon .png file in the Assets folder of the project. The icon becomes blurred after building.
- The issue occurs in iOS, Android and standalone builds.

Reproduced on:
5.5.0a1, 5.4.0b23

Did not reproduce:
5.3.5p5, 5.2.4f1

Comments (24)

  1. 6439da9f2d464b7f1a198611b9059b88?d=mm

    tanapp

    Dec 07, 2017 13:31

    Still happening with 5.6.4

  2. 29a331efc06d5c5f483131422d67f766?d=mm

    CriticalNoob

    May 23, 2017 07:06

    aparrently the bug still occures, not only are my own textures blured but the Unity UI icons such as gameObject icons or even Unity splash screen after build are all blured, I'm so confused now

  3. 0219062c13bc392e84ea7f48531b9bde?d=mm

    aiyra

    Oct 28, 2016 15:22

    Hey everyone,

    Just a heads-up: 5.4.2p2 is out and the fix is mentioned on the changelog. We've tested and, so far, it appears that the bug is ideed fixed, finally.

    You can get it here: https://unity3d.com/unity/qa/patch-releases

    King regards,

  4. 65b78d75ca8bf92d7e049056a51d00bd?d=mm

    Malishev

    Oct 25, 2016 17:43

    please fix this!
    My icons are so ugly ((

  5. 0219062c13bc392e84ea7f48531b9bde?d=mm

    aiyra

    Oct 25, 2016 12:55

    Hey guys.
    As said on the discussion that is happening here https://forum.unity3d.com/threads/build-icon-blurred-in-version-5-4-0f3.419601/, it seems that now it is going to be fixed on the upcoming 5.4.2p2

  6. 6d72083be05cc5776d69453ef0ff0edf?d=mm

    spelkraft

    Oct 24, 2016 17:25

    I can confirm that it has not been fixed in 5.4.2p1.

  7. 0219062c13bc392e84ea7f48531b9bde?d=mm

    aiyra

    Oct 24, 2016 15:08

    Hey, everyone.

    Patch 5.4.2p1 was released today but, as far as we know, the bug is still there. We found no evidence about it on the changelog (https://unity3d.com/unity/qa/patch-releases). Please correct us if we're wrong about this.

    Let's hope 5.4.3 to be indeed released this week with the correction, as said.

    Kind regards.

  8. B1f2e2855309c5c78a8cdb93b9eca7b3?d=mm

    Denvery

    Oct 20, 2016 21:25

    Thank you, AIYRA!

  9. 0219062c13bc392e84ea7f48531b9bde?d=mm

    aiyra

    Oct 20, 2016 16:28

    Hey guys,

    We are having problems with this too. After we realised that it was not fixed on 5.4.2 as promised, we've sent an email to Unity support.

    The answer:

    "Hi,

    Thanks for the email.

    Having spoken to our tech team, they have stated that the fix is on its way. They are expecting to ship this in 5.4.2p1, and eventually 5.4.3, which should be next week.

    Thank you for your patience, and I hope this fix works for you as intended!

    Please let me know if you have any further questions.

    Kind regards,"

  10. 48049a5dc5c4bafe1f43de3a72c528f9?d=mm

    bjoern-bartels

    Oct 17, 2016 08:50

    Where is the new case in the issue tracker?
    I am having the same issue as well (also using 5.4.2f1) for months now and it's really, really annoying when deploying. Also it's quite sad how long this issue persists already.

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.