Search Issue Tracker

Fixed in 5.3.0

Votes

9

Found in

5.1.0f2

Issue ID

698724

Regression

Yes

FMOD::Sound instance for resource error

Audio

-

To reproduce:
1. Open GLTest.zip project
2. Open GameLoader scene
3. Run custom builder in top of Editor menu. Build->Game build and select temp folder
4. Copy file from AssetBundles.zip to temp folder
5. Press play
6. Notice "Error: Cannot create FMOD::Sound instance
for resource..." error

Comments (61)

  1. Db0568ef4f1b599323fc7a9e07a1ed86?d=mm

    sunxdc15

    Aug 25, 2016 07:18

    still have such issue in 5.3.4p4 please reopen it.

  2. 0b8324417e7e4da7d7af7a4d389b73dd?d=mm

    sebas86

    Jul 25, 2016 14:39

    I get similar error after updating from 5.3.5p5 to 3.3.6:
    "Cannot create FMOD::Sound instance for resource archive:/CAB-xxx.resource, (File not found. )"

    In my case problem was caused by two elements:
    - sound clip with enabled streaming,
    - unloaded asset bundle after getting sound clip from it.

    Changing sound clip settings from "streaming" to "keep compressed in memory" or "decompress on load" solve problems. Also keeping asset bundle in memory as long as sound streamed sound clip is needed also solves problem.

  3. 8a70804e6f717737b4b911fd772d1e93?d=mm

    mmoczkowski

    Jul 21, 2016 17:26

    For the love of god, this is still not fixed. Happens in 5.3.5f1 and 5.4.0f1

  4. 05e6df6adc6a1b0edb5e3cc6b170967c?d=mm

    nezbo

    Jul 13, 2016 13:53

    I managed to avoid the issue in my project by delaying the loading to some frames later, so the problem is probably due to something in the engine which is not entirely ready yet at that time.

  5. 05e6df6adc6a1b0edb5e3cc6b170967c?d=mm

    nezbo

    Jul 11, 2016 12:04

    And 5.3.5p7

  6. 05e6df6adc6a1b0edb5e3cc6b170967c?d=mm

    nezbo

    Jul 11, 2016 07:14

    I am also still experiencing this bug in Unity Pro 5.3.5f1. Please re-open the issue :)

  7. 42be027eda1253875856a9e49704d32e?d=mm

    amelootstijn

    Jul 08, 2016 11:01

    I'm getting this error in Unity 5.3.5p2

  8. 7c335bec07415d23d58a25e82c95bb0b?d=mm

    ChiuanWei

    Jul 08, 2016 03:04

    still got this error in Unity5.3.5f1

  9. F61107337b24aec1a8662a2f6b5b5ff8?d=mm

    AdventureproGames

    Apr 26, 2016 20:59

    I believe this issue, post 5.3 fix, this error can pop up based on the path of the file you're trying to load. I got this error when attempting to load a file via the www object, but when I moved the file to a different location on the disk, the loading worked.

    I then tried loading any of the .wav files in the original location, and none of them would load until moved to a different folder.

    I will attempt to set up a concrete example when there is time, but maybe this information will help you.

  10. 8832fdcf33eb62c86b3a3ce430d9f3e9?d=mm

    marcuspitz

    Apr 16, 2016 20:52

    I had the same issue when "split" APK (Error: Cannot create FMOD::Sound instance for resource). For correct this, i uncheck "Preload Audio Data" for all Audios (Assets .wav) in the game.

    My Unity version is 5.3.4f1.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.