Search Issue Tracker

Not Reproducible

Votes

14

Found in

5.2.0f2

Issue ID

722288

Regression

No

Bold font .ttf file is not detected properly for certain fonts

uGUI

-

-

Priority: 3Not yet prioritized for a release

-

Severity: 0Severity not yet defined

How to reproduce:

1. Open attached project
2. Open scene Scene.unity
3. Try switching between Normal and Bold font style on gameobject Main Camera/Canvas/Bold
- Note how the font only gets wider, but not properly bold
4. Import attached Bold version of the font
5. Try switching between Normal and Bold styles again
- Note how it still only gets wider, even though the Bold version of the font is present
- A possible workaround is to use the Bold version of the font directly, rather than through Font Style

Comments (33)

  1. 3f57b68dad165063b20e8736047ac856?d=mm

    lexacutable

    Feb 29, 2016 02:38

    Update - the fonts are now fixed after re-importing them!

  2. 3f57b68dad165063b20e8736047ac856?d=mm

    lexacutable

    Feb 29, 2016 02:37

    5.3.3p1, still broken here.

    Oddly, it was working fine (in 5.3.3p1) until I switched over to a different computer to develop on. Now fonts are broken again.

  3. 5cd7ba5ad8eda579d225882c83a01e14?d=mm

    Andrew-Cogmation

    Feb 01, 2016 20:05

    5.3.2... still not fixed.

  4. 037d0f80d4cf1a442bef1c47280a747d?d=mm

    wayfarergames

    Jan 27, 2016 11:52

    Definitely NOT resolved - using 5.3.1f1.

  5. C0b18c79394074f49a66a2fa7e07f98a?d=mm

    AppSavy

    Jan 22, 2016 17:05

    I'm on version 5.3.1f And can confirm this issue is still here and NOT fixed. wtf

  6. 2156666ee30058985baee3a0164ba93e?d=mm

    fokziu

    Jan 08, 2016 13:33

    I can also confirm that this is NOT fixed. I am amazed by _what_ and _how_ Unity is doing that they randomly break lots and lots of stuff from release to release. Really unhappy with Unity at the moment.

    Just to be sure, is there ANY convetion we should follow for the Font component to catch up on the proper face files? For instance should the variants be called with hyphen or underscore or what? (e.g Arial-bold Arial-italic Arial or Arial-regular?)

  7. 0cb658a22bdaf24400554afb4b253de5?d=mm

    marcelop

    Dec 08, 2015 22:14

    I can also confirm this is not fixed on 5.3.0f4.

  8. 5701d8f48dd6408c390fd206142324f4?d=mm

    TeorikDeli

    Dec 08, 2015 17:46

    I can assure you, this bug is not solved in 5.3. Bold letters still gets wider, not bolder. Am I missing something?

  9. 5701d8f48dd6408c390fd206142324f4?d=mm

    TeorikDeli

    Oct 23, 2015 17:58

    I still have this problem in 5.2.2f1 =/

  10. 6d61aa929f115064aa6e286e58704d53?d=mm

    do2

    Sep 30, 2015 04:31

    I'm using .otf fonts and whenever i'm trying to use the bold tags for a rich text, i get the same result. The letters inside the bold tag are only widened, but not bold.

    This issue persists on unity 5.2.1

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.