Search Issue Tracker

Fixed in 2020.1.X

Fixed in 2018.4.X, 2019.3.X



Found in










Issue ID




UnityWebRequest fails to verify certificate when "Let's Encrypt Authority X1" certificate is present in system trust store



Reproduction steps:
1. Open Certificate Manager (In Windows, search for "Manage user certificates" in the Start menu)
2. If present, delete Let's Encrypt Authority X3 certificate under "Current User\Intermediate Certification Authorities\Certificates"
3. If not present, install the Let's Encrypt Authority X1 certificate attached below
4. Open the attached project (
5. Enter Play Mode

Expected result: WebRequest is successful and data is fetched
Actual result: The error "Curl error 51: Cert verify failed: UNITYTLS_X509VERIFY_FLAG_NOT_TRUSTED" is thrown and no data is fetched

Reproduced in: 2018.4.10f1, 2018.4.16f1, 2019.2.7f2, 2019.2.19f1, 2019.3.0b4, 2019.3.0f6, 2020.1.0a4
Not reproducible in: 2017.4.36f1, 2018.4.9f1, 2019.2.7f1, 2019.3.0b3, 2020.1.0a3, 2020.1.0a11, 2020.1.0a21

Regressed in: 2018.4.10f1, 2019.2.7f1, 2019.3.0b3, 2020.1.0a4, most likely caused by Case 1076758

  1. Resolution Note (fix version 2020.1):

    Fixed in 2020.1.0a11

  2. Resolution Note (fix version 2019.3):

    Fixed in 2019.3.3f1

  3. Resolution Note (fix version 2018.4):

    Fixed in 2018.4.18f1

Comments (47)

  1. tobiaswoodman

    May 08, 2020 12:53

    Happened to me just today. Never before, version - 2019.2.12.f1

  2. sureyaK

    May 08, 2020 12:52

    2019.2.17f1 Started to appear in Editor just today

  3. xWilQ

    May 08, 2020 12:51

    Just got this error today with Unity 2018.4.21f.
    Have not gotten it before.

    Curl error 51: Cert verify failed: UNITYTLS_X509VERIFY_FLAG_EXPIRED

  4. Vickrpg

    May 08, 2020 12:50

    got the Curl error 51: Cert verify failed: UNITYTLS_X509VERIFY_FLAG_EXPIRED error on 2019.3.0f6 today. first time. Spams editor even in new blank projects.
    spams editor in old projects.
    prevents editor functions in the inspector from working correctly at random also.

  5. CedricMorelFrancoz

    May 08, 2020 12:50

    Same problem. What's the solution ?

  6. Lividus

    May 08, 2020 12:49

    Got same error today. Unity 2018.4.21f

  7. resland

    May 08, 2020 12:46

    2019.2.12f1 the same issue...

  8. Nico8292

    May 08, 2020 12:46

    Just happened to me too with 2019.2.12f1. Cannot run my project.

  9. Xerendil

    May 08, 2020 12:37

    Happened to me just now in 2019.2.21f1.

  10. Drakkashi

    May 08, 2020 12:30

    Getting this is 2018.4.22f1, still not fixed.
    I have no idea why I'm getting it, but it's positively infuriating to have my console spammed with this error for no particular reason.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.