Search Issue Tracker

Fixed in 5.6.0

Votes

214

Found in

4.6.2f1

Issue ID

668043

Regression

No

UnityEngine.UI.dll is in timestamps but is not known in guidmapper...

Error message shown on first open of attached project:

Asset 'C:/Program Files (x86)/Unity/Editor/Data/UnityExtensions/Unity/GUISystem/4.6.0/UnityEngine.UI.dll' is in timestamps but is not known in guidmapper...

Comments (87)

  1. F514af08d2b5a84baaefb3d94cccfaed?d=mm

    blankatmcard2022

    Mar 17, 2022 00:23

    GET RICH WITH BLANK ATM CARD ... Whatsapp: +18033921735

    I want to testify about Dark Web blank atm cards which can withdraw money from any atm machines around the world. I was very poor before and have no job. I saw so many testimony about how Dark Web Cyber hackers send them the atm blank card and use it to collect money in any atm machine and become rich.(dwchzone@gmail.com) I email them also and they sent me the blank atm card. I have use it to get 250,000 dollars. withdraw the maximum of 5,000 USD daily. Dark Web is giving out the card just to help the poor. Hack and take money directly from any atm machine vault with the use of atm programmed card which runs in automatic mode.

    You can also contact them for the service below

    * Western Union/MoneyGram Transfer Hack

    * Bank Transfer Hack

    * PayPal / Skrill Transfer Hack

    * Crypto Mining Hack

    * CashApp Transfer Hack

    Email: dwchzone@gmail.com

    Text & Call or WhatsApp: +18033921735

  2. 7dcdf89c18d333e2e8c29fb23d5ba956?d=mm

    swedhaalex

    Feb 16, 2020 09:40

    I Have an issue please solve it!
    The AssetDatabase contains a timestamp for 'ProjectSettings/NetworkManager.asset', but no mapped GUID. This timestamp will be removed from the database.
    UnityEditor.GenericMenu:CatchMenu(Object, String[], Int32)

  3. 40fddcd167f138048a50259399b62a90?d=mm

    Talginsta

    Oct 18, 2017 16:28

    You can also reimport all assets. In my case this method solved the problem.

  4. 580ee47d586cfe40af3f736a60b6ef83?d=mm

    StarvingIndieDeveloper

    Oct 16, 2017 20:53

    Here's the method I use:
    Close Unity, then go to <Unity directory>\Unity\Editor\Data\UnityExtensions\Unity\GUISystem\ and delete UnityEngine.UI.dll (or delete both files named that) then go into the Editor folder in the above directory and also delete UnityEngine.UI.dll (same name) in that folder (likewise I usually delete both files with that name, for a total of four); then restart Unity, access the project and scene where the problem occurred, but then immediately close it again without doing anything; then go to the Recycle Bin and restore the deleted files - just click on them and right-click then select Restore. Can select all of them at once and then right-click to restore all of them. Then restart Unity and there shouldn't be any errors

  5. 40fddcd167f138048a50259399b62a90?d=mm

    Talginsta

    Oct 16, 2017 11:08

    In my case this problem was solved by turning off the Google Sync or moving the folder of the project from Google Disc. I think while the synchronization process is going on... the files are allocated by either of them, then (e.g. when files are reserved by the Google Sync) saving process cannot be done and the Unity throws an exception.
    1. Try to switch off sync when you are working with this project
    2. Move the folder of the project to another place (and sync only after you finish working on this project).
    Hope the will help you! :)

  6. 548a20a79f4cbc956d6117a6583221aa?d=mm

    qartopu

    Jan 21, 2017 09:15

    i just go to this folder
    C:\Program Files\Unity\Editor\Data\UnityExtensions\Unity\GUISystem
    and select UnityEngine.UI.dll file & right click & properties & security & Edit & change
    all group and Usernames to full control
    and close unity again open
    and Done

  7. E2a3030b2d2d5ec506d95250e0d9dbcd?d=mm

    horvatha

    Jan 16, 2017 07:34

    I'm having this bug still on 5.5.0f3... I'm getting this issue for a lot of .dll files (32 to be exact) and have been unable to fix it on my own. Even trying workarounds such as VDESCUBESSEP's method did not work.

  8. Bffb70ef6bfc45236aeca47fefbf1c25?d=mm

    yang-yu

    Jan 13, 2017 02:30

    Unity 5.3.6p5 still have this problem, plz fix

  9. 7eb48cf50917184e7924aea43e16ea3e?d=mm

    CarterG81

    Dec 15, 2016 13:38

    Thanks for the temporary fix VDESCUBESSEP. That worked for me.

    Idk what version this claims it's fixed in, but I am using the most updated version as of today (5.5) and just got this bug.

    VDESCUBESSEP 22, 2016 00:25
    I have to close Unity, move the content from Data\UnityExtensions extensions folder to a temp place, open Unity, close Unity, move the content back back, open Unity.
    The work around lasts until it breaks again...

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.