Search Issue Tracker

Fixed in Unity 5.4.0

Votes

5

Found in

5.3.3f1

Issue ID

778562

Regression

No

Unity fails to import .blend when Blender 2.77 is installed (Windows Only)

Asset Import

-

-

Priority: 7Not yet prioritized for a release

-

Severity: 3Secondary functionality broken

Steps to reproduce:

1. Install Blender 2.77 (http://wiki.blender.org/index.php/Dev:Ref/Release_Notes/2.77)
2. Open blender and save already created cube as .blend file
3. Open Unity and create new project
4. Drag that .blend file to project window
5. When importing, blender stops responding and error is printed in Unity console:
Blender could not convert the .blend file to FBX file.
You need to use Blender 2.45-2.49 or 2.58 and later versions for direct Blender import to work.
UnityEditorInternal.InternalEditorUtility:ProjectWindowDrag(HierarchyProperty, Boolean)
UnityEditor.DockArea:OnGUI()

Alternatively:
Import attached "broken.blend" file but make sure that blender 2.77 is installed.

Workaround: export to fbx using blender and then import that fbx to Unity

Reproduced with: 5.1.4f1, 5.2.4f1, 5.3.3p3, 5.4.0b10

Comments (18)

  1. Ea5f6c72dc8db3679fbd44e75ebd3336?d=mm

    bjaubert

    Apr 11, 2016 10:45

    It seems that the issue is still not fixed (Blender 2.77a and Unity 5.3.4 f1). I have the same error than the one described in the main post.

  2. 995f649c0bbfc060fc7c521338e80909?d=mm

    EiknarF

    Apr 10, 2016 15:15

    Not sure if this helps anyone but I was having the problem since 2.77 release then upgraded to windows 10 and the problem was fixed. Might explain why there seems to be some confusion with people not being able to tell if the bug is fixed or not.

  3. A62bf8eb4611054dd83518b11ddb265d?d=mm

    bolaum

    Apr 02, 2016 18:52

    This is not fixed.

  4. 31dd707ba6eb36ec8ba879b35033d446?d=mm

    Lucashrc

    Apr 01, 2016 02:54

    The problem is not matter if you mind .fbx and for an animated object for example, any changes you make will have to reconfigure it in unity all over again, intão work with .blender is easier to edit

  5. 701d623469471c90b27e14668dacf49f?d=mm

    Nyukkah

    Mar 30, 2016 22:33

    Does not work with 5.3.2f1 nor 5.4.0b10
    Downgrading blender to 2.76b fixed the issue.

  6. B2e6a057e347b3d505b320a3602ad4b3?d=mm

    Edtion

    Mar 27, 2016 20:04

    Yeah, I requested this and I was told they'd send it to the developers to see if it's a Unity bug and told me that workaround like I didn't already know that. I also told Blender report first and they told me to go tell Unity to find out if it's a Unity thing.
    -_-

    Both are point the finger at each other and just ignoring and marking the problem as solved.
    I'm reposting to both because SOMETHING isn't working right and a circle of blame isn't going to fix it, nor will avoiding and ignoring it.

  7. B797449429747ef4341b4939a00b2ce8?d=mm

    Flavelius

    Mar 24, 2016 10:15

    This isn't solved in 5.3.4f1 (the 'stable' release)

  8. 12328800817eaf9b86109a3c817310dc?d=mm

    Postrock

    Mar 22, 2016 18:46

    sorry i dont understand how is this fixed..will it be in a next release?

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.