Search Issue Tracker

Fixed in 5.4.0

Votes

5

Found in

5.3.3f1

Issue ID

778562

Regression

No

Unity fails to import .blend when Blender 2.77 is installed (Windows Only)

Asset Import

-

Steps to reproduce:

1. Install Blender 2.77 (http://wiki.blender.org/index.php/Dev:Ref/Release_Notes/2.77)
2. Open blender and save already created cube as .blend file
3. Open Unity and create new project
4. Drag that .blend file to project window
5. When importing, blender stops responding and error is printed in Unity console:
Blender could not convert the .blend file to FBX file.
You need to use Blender 2.45-2.49 or 2.58 and later versions for direct Blender import to work.
UnityEditorInternal.InternalEditorUtility:ProjectWindowDrag(HierarchyProperty, Boolean)
UnityEditor.DockArea:OnGUI()

Alternatively:
Import attached "broken.blend" file but make sure that blender 2.77 is installed.

Workaround: export to fbx using blender and then import that fbx to Unity

Reproduced with: 5.1.4f1, 5.2.4f1, 5.3.3p3, 5.4.0b10

Comments (18)

  1. F041ccf24524caf8d010097770b5eeae?d=mm

    Norgg

    Sep 05, 2016 16:59

    This was still broken in 5.4.0p1 for me, but fixed in 5.5.0b1!

  2. 1c80136c2a328455f33d10245bbd0a8d?d=mm

    avestea

    Aug 23, 2016 12:13

    Still not fixed in 5.3.5f1

  3. F2c67e39b28477cc0eaab0ded86b0d69?d=mm

    Kerosini

    Aug 09, 2016 19:40

    I have the same issue with blender 2.77 & Unity free license 5.3.4f1. It is is not fixed :(

  4. C53d9c503b2692bf832f666f81b14383?d=mm

    MrSoad

    Aug 09, 2016 13:24

    I can't import any .blend file(from various version spanning over three years) into Unity(5.3.4f1) on my Win 7 64 system via any method I know. I get the error message "Blender has stopped working" whenever I try. This is not fixed...

  5. 0e867e2507d99d6af175a428f42a3ce1?d=mm

    Germanunkol

    Jul 26, 2016 08:22

    The exact same thing happens to me with:
    - Blender 2.76b
    - Unity 5.4.0
    on Ubuntu Linux 16.04.

    Not fixed, from what I can tell...

  6. Ef5fe79b7a24eb630ed1f047b275c24e?d=mm

    minev

    Jul 23, 2016 09:51

    Issue seems to exist only on Windows 7.
    Since 5.4 is a beta version, problem should not be marked as 'Fixed' if it still persists in latest production ready release version.

    I hope it gets fixed for both 5.3.5 (I have it), or 5.4 comes out of beta soon.

  7. 199da32610118b383189cdc237a857fb?d=mm

    Pat-AfterMoon

    Jul 20, 2016 21:28

    Just for info, I've tried the "steps to reproduce" and got no bug.
    Windows 10, Unity 5.3.5f1, Blender 2.77a

  8. 49caca3fd65c645c620ddce389495ecf?d=mm

    jdm

    Jun 08, 2016 15:59

    Not fixed. Though, it seems like it could be a 5 minute fix, since Blender works just fine on Windows for exporting to FBX. Maybe not though, depends on the API. This really damages the workflow on Windows to not have it updated. I'd go so far as to say Blender->Unity workflow not working is a serious problem for rapid iterative development. Blender devs said they don't have an issue, which I agree with. They don't. Their FBX exporter does work. It seems Unity devs need to update their support for this. Many people use Blender and this is crippling for those Windows folks. Thankfully I can just move to my Mac, but still it's kind of annoying.

  9. 57bb7614567ceef271a3cb1821ec3566?d=mm

    kebrus

    Apr 26, 2016 12:39

    Correct me if I'm wrong but maybe it's marked as fixed because it's not a unity problem anymore. Like you guys said, it's the 2.77 version thats giving the problem, and I'm sure I had this problem with some older blender versions as well and the solution was always reverting and waiting to a working blender version.

  10. 59bcd3fc228bf4f09f380d25a072a898?d=mm

    squared55

    Apr 20, 2016 04:02

    This is still not fixed. I've suddenly started getting this exact problem as well.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.