Search Issue Tracker

Not Reproducible

Fixed in 2017.1, 2017.2

Votes

13

Found in

2017.2.0b1

Issue ID

923633

Regression

Yes

Unity extensions are not yet initialized assertions at project opening

Scripting

-

Editor throws assertions at project opening

For repro open attached project. It's switched to Universal Windows Platform with scripting runtime version 4.6 and VS 2015 is set as external code editor.

Assertion should appear:

Assertion failed: Unity extensions are not yet initialized, so we cannot say if the 'C:/Program Files/Unity 2017.2.0b1/Editor/Data/UnityExtensions/Unity/UnityHoloLens/Runtime/UnityEngine.HoloLens.dll' is compatible with platform WindowsStoreApps
UnityEditorInternal.InternalEditorUtility:GetPrecompiledAssemblies(Boolean, BuildTargetGroup, BuildTarget)
UnityEditorInternal.InternalEditorUtility:GetMonoIslandsForPlayer() (at C:/buildslave/unity/build/Editor/Mono/InternalEditorUtility.cs:377)
System.Reflection.MethodBase:Invoke(Object, Object[])
SyntaxTree.VisualStudio.Unity.Bridge.CompilationUnit:CompilationUnits(String)
SyntaxTree.VisualStudio.Unity.Bridge.CompilationUnit:CompilationUnitsForPlayer()
SyntaxTree.VisualStudio.Unity.Bridge.ProjectSystem.UnitySolutionBuilder:CreatePlayerProject(CompilationUnit)
SyntaxTree.VisualStudio.Unity.Bridge.ProjectSystem.UnitySolutionBuilder:CreateSolution()
SyntaxTree.VisualStudio.Unity.Bridge.ProjectSystem.UnitySolutionBuilder:CreateSolutionFromAssetDatabase()
SyntaxTree.VisualStudio.Unity.Bridge.ProjectFilesGenerator:GenerateProject()
SyntaxTree.VisualStudio.Unity.Bridge.ProjectFilePostprocessor:OnPreGeneratingCSProjectFiles()
UnityEditor.SyncVS:SyncVisualStudioProjectIfItAlreadyExists()

Comments (17)

  1. Dd63b1f7c45fb64c16f870bc63674807?d=mm

    ventsie

    Jun 24, 2019 08:49

    Same issue here with Unity 2018.2.13f1 happening on new projects too. Closing the bug, because it is "Not Reproducible" is appalling when so many people are claiming to have the same error.

  2. 44e2a54ff60e05eab5cd58e9cfd915b1?d=mm

    travelhawk

    Mar 13, 2019 15:13

    same error in Unity 2018.2.15f1
    Don't know what to do =(

  3. 14014699f49cf6202ccfea020988a7ed?d=mm

    alexrau

    Dec 18, 2018 01:08

    On this thread (https://issuetracker.unity3d.com/issues/il2cpp-unity-extensions-are-not-yet-initialized-errors-are-thrown-when-opening-project-with-target-platform-set-to-uwp ) it is reproducible and marked as closed with fix being to upgrade to 2018.3, guess I need to do that and deal with all the other asset and compatiablity issues.
    I think that the bum GitHub plug was what introduced it to my project.

  4. E2034baaa33746e72db66e2a3c56fb43?d=mm

    joschemd

    Nov 28, 2018 22:27

    Getting this with a new project on 2018.2.17f1 (88933597c842)

  5. A57022f24fee1b171642f5f1de5e6945?d=mm

    rickblacker

    Nov 21, 2018 20:36

    Yep me too. 2018.2.16f1
    Over 726 errors

  6. F08010ae66e1e7030f14df17db524b78?d=mm

    ionusprimus

    Nov 10, 2018 05:43

    Still there in 2018.2.15f1. Isnt that a bit of a head in the sand attitude to just say you cant reproduce it therefore it doesnt exist ?? What have you tried ??

  7. 0da9162ce6c42ee278ec0b0ad37a8e39?d=mm

    ph2k

    Oct 09, 2018 11:19

    Also getting this, its annoying if anything.

  8. B93496ecac015d4e734cdc3358fdf04c?d=mm

    DemonGamesStudio

    Oct 06, 2018 23:21

    Getting this too, incredibly annoying.

  9. Fbbc3dc0c6822d0e4b2012960f7d7cb0?d=mm

    OStkMS

    Oct 01, 2018 07:24

    Same with me using Unity 2018.2.9f1
    Clean setup using UWP, PiXYZ, Playmaker and Vuforia, MRTK

    Unity extensions are not yet initialized, so we cannot say if the '.../GoogleAudioSpatializer.dll' is compatible with platform WindowsStoreApps.
    Not only GoogleAudioSpatializer, there are 121 errors...

  10. 289e71ee9ddc88a0559c659900318ae1?d=mm

    KyleStorck

    Aug 13, 2018 16:31

    I am seeing these 100 of these errors also when trying to build a UWP project on 2018.2.2f1

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.