Search Issue Tracker

Not Reproducible

Votes

32

Found in

5.4.0b22

Issue ID

805222

Regression

Yes

SUCCEEDED(hr) error message after editor regains focus

IMGUI

-

1. open succeded scene
2. expend canvas and select button
3. hit the color widget in image script to change its color
4. hit the color picker button
5. select a color anywhere
6. close color picker
7. hit anywhere in wondows away from unity
8. re-click scene view
9. redo steps 4 to 8.

result: SUCCEEDED(hr)
rc.right == m_GfxWindow->GetWidth() && rc.bottom == m_GfxWindow->GetHeight()

Found in 5.4.b22

Comments (43)

  1. D6e551854c98c2086e4a6cf3689e8c6b?d=mm

    soleron

    Feb 15, 2021 20:40

    Same issue 2020.2.f1 ...

  2. 36c65e3934745df83910152c6a077e4a?d=mm

    shubhamswaraj2021

    Aug 18, 2020 15:52

    good one <a href="https://www.lyricsauto.com">lyricsauto</a>

  3. Eed40c66f796a3a2e5f9428f625227f2?d=mm

    IsuruAkalanka

    Aug 14, 2019 02:25

    same problem, I'm a fresh unity user and I even cannot start a single project. This error comes.Please help Unity.

  4. 1a3d22d4da8ab199ae8bac959c8242ae?d=mm

    Koala_Squad

    Apr 07, 2018 02:33

    Found. Error appears after reopening unity after shutting it down due to an infinite loop. I discovered the cause of this instance, but not the reason.

    GameObject image = Instantiate (ImagePrefab, transform.position, transform.rotation, transform);

    Renaming the "ImagePrefab" variable to "ImagePrefabTest" solved problem. Reverting to "ImagePrefab" does not bring issue back. Issue won't return now. Could have something to do with the prefab not linking correctly to the variable the first time, but it appeared fine.

    This is a REALLY weird bug. I'm sorry that it's so hard to reproduce, but please fix this unity!

  5. 99a3624dff43fc004392569e9efde9ab?d=mm

    mgto

    Feb 24, 2018 07:29

    5.6.5p2
    no VR game
    just jet encountered on my laptop mobile geforce 9600M GT dx10 gpu
    driver 342.01
    win10

    D3D11: Failed to create RenderTexture (749 x 413 fmt 9 aa 1), error 0x8007000e

    InitD3D11RenderColorSurface: VRDevice said it created a texture, but the texture is NULL. VR platform drivers may be running with elevated privileges.

    D3D11: Failed to create RenderTexture (749 x 413 fmt 19 aa 1), error 0x8007000e

    Assertion failed on expression: 'SUCCEEDED(hr)'

    camera output turns black
    seems to be related to unities post processing behaviour (disabling this component makes camera "work" again, enabling it outputs black again)
    "black" means: dithering from the post processing behaviour still visible. also GUI

  6. 5bc10b7643e6af3caea1dd248c2f61e2?d=mm

    pci

    Feb 26, 2017 05:48

    Just encountered this today -- close editor and it goes away for a while and comes back. Somebody needs to track down an isolated repro. Unity seems to be unable to figure this out on their own.

  7. 4b409f54d7f61f76c11235a7d138d4dd?d=mm

    tcz8

    Feb 23, 2017 17:50

    Same problem.... do you guys all have a multi monitor setup?

  8. 033fecabe797b933929d65ed51243047?d=mm

    NlaakStudios

    Feb 12, 2017 22:44

    I am getting the error. Even tried going back to Unity 5.4 stable. When i editor gets focus i get 44 errors. I cannot track it down.

  9. 62e6574debc8ad8377a7a1b9a4063be3?d=mm

    nxrighthere

    Jan 30, 2017 03:37

    Unity dev team hello, how do you testing your sofrware? This problem is still here (Unity 5.5.1f1)!

  10. A79cda4d4ab7e50131a86c3463a8c120?d=mm

    KCAR

    Jan 15, 2017 04:10

    Jan 14, 2016, Error still occuring

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.