Search Issue Tracker

Fixed in 2018.3

Fixed in 2017.4, 2019.1

Votes

58

Found in

2018.2.11f1

Issue ID

1089060

Regression

No

Sounds do not play in WebGL Builds when launched in Safari 12

WebGL

-

How to reproduce:
1. Open the Project attached by the user (test.zip)
2. Open the "SampleScene" Scene, play it, notice the sound
3. Build the Project for WebGL
4. Launch the Build with Safari 12
5. Notice how sound is not playing in the Build

Expected result: Sound works in the Build
Actual result: Sound does not work in the Build

Reproducible with: 2017.4.0f1, 2017.4.13f1, 2018.1.9f2, 2018.2.12f1, 2018.3.0b5, 2019.1.0a4

Notes: I could not test it with previous Safari versions, but I'm assuming the problem only occurs in Safari 12, as I've tested with another MacOS version which also had Safari 12 and the problem reproduced.

Comments (12)

  1. 91309587c8db6442fa44f393d52348fe?d=mm

    Thoptv

    Jun 21, 2019 08:39

  2. 4073711f691e7b5952a438b672ccbc48?d=mm

    patsm00re18

    Jun 19, 2019 11:22

    Download mobile legend is an online game that requires high-intensity teamwork and strategic planning. With different types of heroes to choose from, choose the best one that suits your gaming style. https://games.lol/mobile-legends-bang-bang/

  3. 91d85c3a5db6f79b195168b22d8df902?d=mm

    alice909

    Mar 21, 2019 05:06

    8volution has provided the correct way to fix this issue because I also faced this issue that time I visited https://uaedatarecovery.com/data-recovery-for-apple-devices/ and there is the same solution was given. It really works

  4. 1bb96bac5b563abc118666e32dcfe1a3?d=mm

    ZhouShuRen

    Dec 27, 2018 05:41

    hope to solve this problem ,I need this. Thank U.

  5. 1bb96bac5b563abc118666e32dcfe1a3?d=mm

    ZhouShuRen

    Dec 27, 2018 05:41

    hope to solve this problem ,I need this. Thank U.

  6. 8d607568a62146cbb84bebd067cc2999?d=mm

    Lord_of_Robby

    Dec 26, 2018 11:08

    Fix this please!!!

  7. Ad4ca2980911c3b897caea1e0fdfe3c8?d=mm

    wechat_os_Qy06pkPKWd52pMgjThsMFaWjQ

    Dec 26, 2018 10:04

    hope to solve this early

  8. 4d2d8d2fcf0220aa1fe4b682471d946c?d=mm

    BlaneHadley

    Dec 21, 2018 15:58

    Here's a link to a thread with a workaround. It's at the tail end. Props to TheRoccoB for the answer.

    https://forum.unity.com/threads/chrome-on-the-dev-branch-version-66-may-block-audio-for-unity-webgl.517758/page-2

  9. 428d078763ff0e39a6ab9b092b52eafe?d=mm

    tony_sumdog

    Nov 13, 2018 17:24

    Also experiencing this. We cannot ask our users to enable auto play in Safari since they are largely young children.

  10. E150bb7499f31db1fd6f490f4a8d9e85?d=mm

    8volution

    Oct 23, 2018 04:19

    Go to Safari > Settings for This Website > Auto-Play. Then, select 'Allow all Auto-Play' and reload the page. This fixed it for me.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.