Search Issue Tracker

Fixed in 5.5.0



Found in


Issue ID




[iOS] Sound volume of music playing on the device gets quiet after launching a Unity app



When a Unity app is launched, any audio playing on the device (iTunes, Spotify, etc.) gets quiet, even when the app is not playing any sounds. This issue does not occur when 'Disable Unity Audio' is checked in Edit > Project Settings > Audio. When the app goes back to background or is exited, the sound goes back to normal.

Steps to reproduce:
1) Create a new project.
2) Build for iOS.
3) Play music on a device.
4) Launch the build on the device.

As soon as the app starts, the sound volume is halved.

Reproduced on:
5.5.0b2, 5.4.0p4, 5.3.6p4

Did not reproduce:

Comments (36)

  1. 8ebd977c0c96f4689f8edbdc0d9c8ba8?d=mm


    Feb 13, 2017 06:37

    It's not solved.
    On all versions of unity, after 5.3.4f1.

  2. 02c004026c5caacdaf9b17c53164bbd6?d=mm


    Jan 25, 2017 10:43

    I still have this bug with 5.5.0f3

  3. 680d10e61268f0642176377a5ffaac4b?d=mm


    Jan 23, 2017 01:19

    I'm seeing this still in Unity 5.5.0f3 on Android.

  4. 08ea81b66af2eb6ca4f93381cd1674ee?d=mm


    Nov 30, 2016 01:54

    Chiming in again to say that this issue appears to be fixed in 5.4.3p1 on my end although I didn't see any specific mention of it in the patch notes.

  5. 8c06310c537108165b451a89282e56ce?d=mm


    Nov 28, 2016 14:47

    5.4.3 is out, still no mention of a fix. Very hard to imagine signing up for the new Unity subscription when I've been unable to ship an update for over a year as my users get angrier. They don't want one bug fixed (also built into Unity, also took months to get a fix) only to discover another one added.

  6. 381399fc532b55a5da76df61822472ae?d=mm


    Nov 23, 2016 18:37

    @LANESTP: Thanks for providing a work around but it doesn't work on iPads for me either, it works on iPhone6 and iPhone7. Any way of activating just for iPhones? Thank you!

    I really hope Unity fixes this asap because it's not only a problem as a developer but also a problem as a gamer, many of the games I'm playing have this issue now!

  7. 07b8371a0ad6e6079c927a129dcc7941?d=mm


    Nov 10, 2016 20:02

    Hi @lanestp ,
    Thanks for the plugin code, and it works on my iPhone6 on iOS 10.0.2, I also got the error the same with @ALECT when it runs on some other devices. But thanks for the code!

  8. 8c06310c537108165b451a89282e56ce?d=mm


    Nov 08, 2016 18:18

    Thanks again, Lanestp! I'll give it a day or two more in hopes of an official fix, and then I'll give that a try!

  9. 08ea81b66af2eb6ca4f93381cd1674ee?d=mm


    Nov 07, 2016 18:46

    @lanestp your code workaround seems to work great on my iPhone 5S running 10.0.1, but on my iPad Mini 2 running 9.3.2 I get the following error and no audio plays at all (this error does not appear and audio works fine without the AudioFix plugin):

    ERROR: [0x19faba000] AVAudioSessionUtilities.h:111: GetProperty: AudioSessionGetProperty ('aiav') failed with error: '!ini'
    ERROR: [0x19faba000] AVAudioSessionUtilities.h:124: GetProperty_DefaultToZero: AudioSessionGetProperty ('aiav') failed with error: '!ini'
    FMOD failed to initialize the output device, attempting to initialize the null output.

    I'm not super familiar with what your code is doing, so I was wondering if you have any insights about how to fix that? Thanks either way!

  10. F0dded27025f0fe56bc3a827a18cfdaa?d=mm


    Nov 04, 2016 02:42

    Morgan - inside your project directory inside assets Create a Plugins directory and inside that creat an iOS directory

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.