Search Issue Tracker

Fixed in 5.3.4

Fixed in 5.4

Votes

79

Found in

5.3.0f4

Issue ID

752613

Regression

No

Error when changing quality settings

Graphics - General

-

Error changing the quality settings, in realtime, from "half res texture quality" to "full res texture quality"

Comments (23)

  1. E98c69fd7d5557293a28ccda20d087bc?d=mm

    cgripeos

    Oct 02, 2018 20:33

    A similar issue is happening on Unity 2018.2.0f2 on packaged PC game (but works fine in the Editor)

    My repro is with textures that don't have mip levels (UI textures). When changing to a quality setting where the texture resolution changes, the UI starts breaking/UI elements wont render and/or react to input.

  2. 628414d17f5aa6a7023e6b54ae705575?d=mm

    TomHaygarth

    Aug 22, 2016 10:56

    Issue exists in 5.3.6f1 on webgl majority of the textures broke when changing from half to full res or vice versa. Most of these assets are downloaded from external asset bundles.

    Could it be related to this https://issuetracker.unity3d.com/issues/changing-to-lower-texture-quality-breaks-baked-lighting

  3. Cfd127a37d6318122b58445d0554d297?d=mm

    chrismarch

    Jul 26, 2016 00:03

    hmm, never mind my previous comment about asset bundles!

  4. Cfd127a37d6318122b58445d0554d297?d=mm

    chrismarch

    Jul 25, 2016 18:57

    Still occurs in 5.3.4f1 with the scene textures if the scene was loaded from an asset bundle

  5. 28642dbe38f77f9866f74c5141c2fcbd?d=mm

    ic3d_jpienbro

    Jul 12, 2016 09:30

    I have this issue in Unity 5.3.5p7 too.

  6. Cb65e4dc52326a4f56275f1031e4a260?d=mm

    Dewedi1

    Jul 02, 2016 20:16

    Still have it Unity 5.3.5f1. PLEASE FIX!

  7. 9143c10a4033e393296e6adb2ba47756?d=mm

    cyryl514

    Mar 19, 2016 20:44

    I have Unity 5.3.4f1 and still have this problem. When running game in Unity Editor everything works fine: http://scr.hu/30dg/52qzw
    After building game on windows textures look like this: http://scr.hu/30dg/ub6vs

    Here is unity error: Trying to reload asset from disk that is not stored on disk
    I also have to say that im loading textures in runitme (game is open for moders).

  8. 876c396c09138644c4eae01775e3ff8f?d=mm

    speedis

    Mar 11, 2016 20:06

    5.3.3p3 fixed the issue for me, thanks!

  9. B744b73942368301d7b87fefbdee4dd6?d=mm

    daggada2

    Feb 21, 2016 00:33

    Issue is still present for me in 5.3.2p4.

  10. Bf36b832217edde1daf6d95af3bc5573?d=mm

    TheLogician

    Feb 20, 2016 15:53

    I also have the same issue in 5.3.2f1 when calling QualitySettings.SetQualityLevel for full res from any lower res. We can't publish with this issue active, please fix.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.