Search Issue Tracker

Fixed in 5.4.3

Votes

24

Found in

5.4.1p2

Issue ID

836165

Regression

Yes

Editor crashes when 'Build And Run' is opening the built Xcode project with macOS Sierra

iOS

-

When "Build And Run" is used to open an iOS build with Xcode, Unity Editor crashes when opening Xcode.

Steps to reproduce:
1) Open the latest attached project (clean_836165_repro.zip).
2) 'Build And Run' for iOS or tvOS.

When building has finished and the progress bar is at 'Build & Install Unity Player", the Editor crashes. The build itself doesn't become corrupted and can still be opened manually.

This issue doesn't reproduce on OS X 10.11.6.

Reproduced on:
5.5.0b6, 5.4.1p3, 5.4.1p2, 5.3.6p6

Did not reproduce:
5.2.4f1

Reproduced on:
Macbook Pro Early 2013, macOS Sierra 10.12

Comments (20)

  1. 0180481ba336ab01d6e4f1924c6d4017?d=mm

    ctc5301

    Jan 06, 2017 06:20

    Seems many of us spend much time to install the variety of Unity versions to find if there's magical to make thing goes smooth. But still bad luck.

  2. 0d877a457bf7732986f0d7f094292e17?d=mm

    Giantheboy10

    Jan 03, 2017 11:01

    same please fix

  3. Ad94902ff0c8036f6e3f60e96046cd18?d=mm

    nako

    Nov 21, 2016 20:13

    Same here with 5.5.0b11

  4. Fa197083235a2bab8e50d30b7f368558?d=mm

    ElCaballeroNegro

    Nov 12, 2016 17:23

    please fix the problem I cant enter when start the program crash some solucion
    if you can understand is beacause i'm not speak english thank if you can answer plis in spanish thank you

  5. 1d98b2e81d3013dbeb9f7dd4c13b676e?d=mm

    wshiahb

    Nov 04, 2016 07:04

    Same here with 5.4.2f2

  6. 0ba5d9fb0b2659b67787c5f0d27a0464?d=mm

    FelipePlets

    Nov 01, 2016 11:41

    Same here with 5.4.2p2

  7. 552b0e005013f0013959046c008bad7a?d=mm

    capitalJmedia

    Oct 31, 2016 19:11

    Same thing for me, OSX Sierra and Unity 5.3.6p8.

  8. Ba8d7c3b4532d3747c30b9be91dc20d5?d=mm

    I33N

    Oct 26, 2016 10:01

    Same problem, Unity get stuck on "build and install iphone player". I have to kill it and relaunch it. Really annoying!

    My config:
    OSX 10.11.6
    XCode 8.0
    Unity 5.4.1f1

  9. 9d5fa497515f849b8ba79d43dd95f509?d=mm

    lawjeremy

    Oct 22, 2016 13:58

    Same issue here. Unity crashes every time I try to 'Build & Run'. I'm using MacOS Sierra and Unity 5.4.2f2. 'Build' still works.

  10. F9ef9c1a04c34625c0a5c95c61f73112?d=mm

    f1chris

    Oct 18, 2016 18:26

    Tested with Unity 5.4.2f1. same issue
    Tested with the Beta 5.5 as well. Same issue.
    Tried to resinstall XCode 8. Same issue.

    Tried the different work arounds and doesn't work for me.

    Running out of solution.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.