Search Issue Tracker

Fixed in 5.4.3

Votes

24

Found in

5.4.1p2

Issue ID

836165

Regression

Yes

Editor crashes when 'Build And Run' is opening the built Xcode project with macOS Sierra

iOS

-

When "Build And Run" is used to open an iOS build with Xcode, Unity Editor crashes when opening Xcode.

Steps to reproduce:
1) Open the latest attached project (clean_836165_repro.zip).
2) 'Build And Run' for iOS or tvOS.

When building has finished and the progress bar is at 'Build & Install Unity Player", the Editor crashes. The build itself doesn't become corrupted and can still be opened manually.

This issue doesn't reproduce on OS X 10.11.6.

Reproduced on:
5.5.0b6, 5.4.1p3, 5.4.1p2, 5.3.6p6

Did not reproduce:
5.2.4f1

Reproduced on:
Macbook Pro Early 2013, macOS Sierra 10.12

Comments (22)

  1. 9d5fa497515f849b8ba79d43dd95f509?d=mm

    lawjeremy

    Oct 22, 2016 13:58

    Same issue here. Unity crashes every time I try to 'Build & Run'. I'm using MacOS Sierra and Unity 5.4.2f2. 'Build' still works.

  2. F9ef9c1a04c34625c0a5c95c61f73112?d=mm

    f1chris

    Oct 18, 2016 18:26

    Tested with Unity 5.4.2f1. same issue
    Tested with the Beta 5.5 as well. Same issue.
    Tried to resinstall XCode 8. Same issue.

    Tried the different work arounds and doesn't work for me.

    Running out of solution.

  3. 15d6766bfa1b7fffee27c079c2bd3135?d=mm

    kirillrybin

    Oct 17, 2016 11:29

    Happens for me with macOS Sierra 10.12, Unity 5.4.2f1.

  4. 7a0fc0cd7cc5459dd61e1c96981f904d?d=mm

    amivarius

    Oct 13, 2016 18:16

    Still happens on 5.3.6p7

  5. 7a0fc0cd7cc5459dd61e1c96981f904d?d=mm

    amivarius

    Oct 06, 2016 05:30

    Same thing here - 5.3.6p6 crashes when it finishes Build & Run for macOS Sierra + XCode 8 - every single time.

  6. Fa5836bab90860f5b491e89fb2405f1c?d=mm

    warren-miller-maltd

    Oct 04, 2016 10:11

    update: you can Build you just can't 'Build and Run'

  7. Fa5836bab90860f5b491e89fb2405f1c?d=mm

    warren-miller-maltd

    Oct 04, 2016 10:02

    happening here too.

  8. D73407fec9fe3705571a22ea0405b9f1?d=mm

    ParityClaws

    Oct 02, 2016 02:44

    Also happening for me

  9. C94207ec930d9c8590a6e2896d3ca7ff?d=mm

    nviro

    Oct 01, 2016 09:06

    Happens for me with macOS Sierra 10.12, Unity 5.4.1p3. Whenever I do a build and run Unity crashes when Xcode is launching. Build still transfers to Xcode though.

  10. 4f2d6d6d672faf025639d860be158d13?d=mm

    Gunplay

    Sep 30, 2016 20:51

    Same thing here! after almost having a game ready for submission to the App Store, I decided to upgrade to Sierra. Been hell the last couple days, I'm downloading El Capitan to see if I can finally finish this project with no more bumps. :P

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.