Search Issue Tracker


Fixed in 2020.3.43f1, 2021.3.14f1, 2022.2.0b16, 2023.1.0a16



Found in





Issue ID




“DrawMeshInstanced does not support…” error in the Console pops up when the Shader does support instanced rendering



Reproduction steps:

# Open the attached project
# Enter the Play Mode
# Hover over the “Potion” GameObject in the Game View
# Observe the Console

Expected result: There’re no errors in the Console
Actual result: “DrawMeshInstanced does not support…” error pops up in the Console

Reproducible with: 2020.3.39f1, 2021.3.9f1, 2022.2.0a8, 2022.2.0b7, 2023.1.0a9
Not reproducible with: 2022.1.0a1, 2022.1.15f1, 2022.2.0a7

Reproducible on: Windows 10 (21H2)

  1. Resolution Note (fix version 2023.1.0a16):

    Fixed incorrect error message displayed due to async shader compilation.

  2. Resolution Note (fix version 2022.2.0b16):

    Fixed incorrect error message displayed due to async shader compilation

  3. Resolution Note (fix version 2021.3.14f1):

    Fixed incorrect error message displayed due to async shader compilation

  4. Resolution Note (fix version 2020.3.43f1):

    Fixed incorrect error message displayed due to async shader compilation

Comments (11)

  1. PyrateAkananto

    Jan 26, 2023 07:52

    Unity Unity 2021.3.17f1 contains the following in the change log:
    "Shaders: Fixed an incorrect error message when using instanced rendering and replacement shaders. (UUM-20961)"
    In our projects the wrong error message is gone when using that Unity version.

  2. andeliseev

    Dec 28, 2022 13:01

    It's also reproduced as 2022.1.23f1.

  3. PyrateAkananto

    Dec 19, 2022 14:51
    The fix will be in 2021.3.17f1 (to be released approximately on 19 Jan 2023).
    EDIT (16.12.2022): 2020.3.44f1 will get it as well. 2022.2 and 2023.1 to follow.

  4. tattyd

    Dec 07, 2022 12:57

    Hi, I'm seeing the same on 2021.3.15f1 as well. Rendering appears fine, but console is spammed.

  5. unity_ESPpfKWcV64y3Q

    Dec 03, 2022 19:36

    It's also reproduced as 2021.3.15f1
    The worse is 2021.3.13f1 it throw the error but gpu instancing work fine on editor and Android/iOS the officer fixed version break the work.

  6. Chalkcs

    Nov 27, 2022 02:39

    Had this issue in 2020.3.42f1, 2021.3.14f1, 2022.1.23f1, and 2022.2.0b16


    Nov 20, 2022 20:27

    I still get the issue in 2021.3.14 in 2 shaders:

    1. Surface Shader (with instancing variants support) + Vegetation Studio Instanced Indirect. If the async shader compilation is disabled, the error goes away. So I think the bug is still not entirely fixed, or there is something missing with the instanced indirect rendering.

    2. VertexFrag Shader + Vegetation Studio Instanced Indirect. This one was missing the multi_compile_instancing pragmas in some passes, so the error is expected.

    I hope this helps narrow down the issues.

  8. VizualNate

    Nov 19, 2022 22:25

    I continue to get thousands of these error messages in 2021.3.14F1 - new installation today.

  9. 03gramat

    Nov 11, 2022 11:41

    This issue has cropped up for a package I maintain which uses both 2020LTS and 2021LTS.

    It floods the error console as I use DrawMeshInstanced at runtime.

    The fixes for 2020 and 2021 would be much appreciated :)

  10. Tanky

    Nov 07, 2022 13:48

    I see that this issue is marked "In Progress", but it's not listed in the Known Issues of the release notes for Unity 2021.3.13.

    This one bug is preventing me from updating Unity. I'm stuck at 2021.3.8. Please prioritize a fix.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.