Search Issue Tracker

Fixed in 2018.2

Fixed in 2017.3

Votes

2

Found in

2017.3.0f1

Issue ID

976439

Regression

No

Can not send network message. Receiver can not keep up with the amount of data sent when deep profiling player

Profiling

-

Steps to reproduce:
1. Open user attached project
2. Build and Run the project with Development Build and Autoconnect Profiler checked (delete the required displayed shader files in the error field if the project does not build)
3. Make sure deep profiling player is properly running
4. Leave the game running for a few minutes
5. Notice "Can not send network message. Receiver can not keep up with the amount of data sent" messages in the player's log.

Expected result: deep profiling data should be properly sent to the editor

Reproduced in: 2018.1.0b1, 2017.3.0f1

Comments (24)

  1. 69adc5c8294c9cc6d05abbd773b9b7a5?d=mm

    LukeFireproof

    Jul 01, 2019 13:45

    This is NOT resolved. Seeing this issue when running unit tests on an android device on unity version 2018.3.13f1

  2. Ab41ed9b992d19b0fce57b2e62fea99f?d=mm

    frederic_unity363

    May 21, 2019 04:24

    using 2018.2.20f1 and not using ARKit, turning off development build, problem occurs only on android

  3. 573f0a24dd0632302213c867b3b1b91a?d=mm

    davenirline

    Dec 08, 2018 13:27

    Just experienced this today. I'm using Unity 2018.2.17.

  4. 5505f9574572edd1103f430cad8631fe?d=mm

    Fillmore

    Sep 20, 2018 18:09

    The quick fix, in the latest version(s) of Unity, is to disable "Development Build".

  5. 17c42327ea95a3f9dc114ff5cb4770b0?d=mm

    saschka

    Sep 07, 2018 06:11

    Yep, Unity 2018.2.6f1 and ArKit 1.5 trying to connect with ARKitRemote.

    Have been getting this since I tried to work with ArKit a few months back and was never able to get ARKitRemote to run.

    Been in all forums and tried everything including the zeroichi fork.

  6. 933eb47463f30e21cbe1090bbc4ca373?d=mm

    Matt-Cranktrain

    Aug 27, 2018 16:26

    Also experiencing this, in 2018.2.3f1. Not using ARKit like some of the other comments are, just regular Unity.

  7. 5505f9574572edd1103f430cad8631fe?d=mm

    Fillmore

    Aug 22, 2018 20:17

    Same issue, error message spammed in xcode output.

  8. 2f1884ffd0d06fa7541684bcfa7857c4?d=mm

    seanomlor

    Aug 17, 2018 03:16

    Here is temporary "fork" with a patch from zeroichi.hatenablog.jp blog post that fixes this issue for me: https://github.com/somlor/unity-arkit-plugin-compress/commit/21629be81b011cfc00af1e963630f7df4583e2de

  9. 4fe7cfb5d55b911fb1ca828dcc7d3f65?d=mm

    5minlab_dev

    Aug 16, 2018 07:04

    still have this issue on Unity 2018.2.2f1.

    I executed a standalone build with 'development build' & 'Autoconnect profiler'.
    and, the application shut down at different timing every time I execute.

    Please fix this one to properly profile the build.

  10. 48381a515479b39da8cc48d5494e02c9?d=mm

    loosecanonstudios

    Aug 11, 2018 14:55

    Is NOT fixed in 2018.2 - I'm seeing it on 2018.2.2f1. It also causes my browser to crash for some reason, and usually causes Unity to become completely non-responsive. I'm testing on Android, over USB, and just watching the profiler tick along when the symptom occurs. Can replicate at will.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.