Search Issue Tracker

Fixed in Unity 5.6.0

Votes

0

Found in

5.6.0b9

Issue ID

885051

Regression

Yes

Camera Depth is ignored when setting both cameras Viewport other than (0;0;1;1)

Camera

-

-

Priority: 2Necessary for shipping a final release

-

Severity: 3Secondary functionality broken

To reproduce:
1. Open attached project;
2. Open "Scene" scene;
3. Click on the "FrontCamera" and set the Viewport to (0;0;1;1)
-notice the Depth is set to 2;
4. Click on the "MidleCamera" and set the Viewport other than (0;0;1;1)
-notice the Depth is set to 1.

Expected result: the Sphere should be in front of the Cube.
Actual result: the Cube is in front of the Sphere unless both cameras Viewport is set to (0;0;1;1).

Reproduced on versions: 5.6.0b1, 5.6.0b9, 2017.1.0a2.
Not reproduced on version: 5.5.2p1.
Regression found in version: 5.6.0b1.

Comments (21)

  1. Df387f0572efaff606bc243de63e9095?d=mm

    OldFrog

    Jul 09, 2018 06:14

    i found it has not been fixed on Snapdragon 845

  2. 93d7d73b6114f829ee634860f671664b?d=mm

    jaspert23

    Jan 14, 2018 11:30

    I ran into this issue yesterday on 2017.3.0f3.

    The only showed up on *some* iOS devices.

    Had to set the viewport to (0,0) - (1.0001, 1.0001) and it fixed it, thank you for the tip AOLLIKAI.

    My setup is three cameras, all persp in render order Background (Clear), Game (no clear), HUD (no clear).

    Issues presented themselves with odd depth smearing artefacts. But not just that, just some really odd screen glitches.

    Seems to me some optimization behavior on default viewport sizes of multiple cameras garbles up the render queue/depth handling.

  3. Fe1bb30bb0cadcf32437467d773f665d?d=mm

    solmyr-fr

    Sep 19, 2017 10:03

    problem still occurs on 2017.1.0f3 only in OSX (also happens in editor) and iOS but seems resolved in windows.

  4. 9bf76080bcc3554b2a5bf726964aed20?d=mm

    gfoxworthy

    Aug 21, 2017 14:23

    Checking in to say that we've had a similar problem in 2017.1.0f3. The camera depth is working for a split-screen camera at {0,0,.3.3}, but the second we move it from the origin it no longer renders properly. This worked in older versions.

  5. 30fb9f701ff40740aefafbe2aaad3bc1?d=mm

    onceabird

    Jul 07, 2017 12:42

    This is not fixed... And it's really bad.

  6. 17b4001caac21dbe92e0b7cb648e8337?d=mm

    Rotecks

    Jun 11, 2017 23:29

    not fixed

  7. 73e7b1c03dcf3fff1e9cf7f572ad55e9?d=mm

    onHead

    May 27, 2017 02:52

    I still have this bug in 5.6.1f1 on Mac OS Sierra too.

  8. 1947e11e49b28904a9b02899843597a3?d=mm

    clater

    May 19, 2017 01:34

    5.6.1 not fixed........

  9. 4ef110131369af3b6e22cedfdc71e611?d=mm

    caletbak2

    May 17, 2017 14:36

    This is still happening in Unity 2017.1.0b5

  10. F3c41659eb586892b351a078ba9c4fb3?d=mm

    coshea

    May 03, 2017 11:22

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.