Search Issue Tracker

Fixed in 2018.3.X

Fixed in 2017.4.X, 2018.2.X



Found in

Issue ID




Android builds fail with Java 9 JDK and Unable to list target platforms error



With the latest public versions of Unity (2017.1.1f1), Android Studio/SDK tools(26.0.2), and JDK (Java HotSpot(TM) 64-Bit Server VM (build 9+181, mixed mode), Android builds failed early on with:

Error:Invalid command android
CommandInvokationFailure: Unable to list target platforms. Please make sure the android sdk path is correct.
See the Console for more details. Error building Player: CommandInvokationFailure: Unable to list
target platforms. Please make sure the android sdk path is correct. See the Console for more details.

A similar problem (same error message, but different cause) has been reported about 6 months ago:

In my case, downgrading to JDK 8 fixed the problem.

Reproduced with:
2017.3.0b4, 2017.2.0f3, 2017.1.2f1, 5.6.3p4, 5.5.5f1

  1. Response avatar


    May 18, 2018

    Unfortunately there are compatibility issues between JDK9 and JDK10 and Android SDK.
    The bugs have been reported to Google, we are working on a full-featured fix.
    As a workaround, for now please UNINSTALL JDK9/10 and INSTALL only JDK8 (64-bit).
    We apologize for the inconvenience caused.

    Feel free to check the status at the forums as well:

Comments (87)

  1. D1738665e6a05b68159d278c89807267?d=mm


    Feb 20, 2018 16:37

    Java 8 + Tools 26.1.1 version working on Unity 2017.3.p1

  2. 2f1e47f42a23fb778d1a9eec84fc0c36?d=mm


    Feb 19, 2018 23:26

    Experiencing same problem after computer rebuild: downloaded latest Android Studio and latest Unity and latest Java JDK. . Temporary fix was revert to Java JDK 8u161 and revert tools using link at

  3. Bc9003da95d3e45aa9b9d7b941102b19?d=mm


    Jan 15, 2018 17:42

    Same problem, same error message, it's not possible to create a build. I have only managed to solve this by downgrading JDK to 8u151 and also the android SDK (r25.2.5 - replacing "tools" folder). I would be really grateful if the developers could fix this, it's been a pain in the ass for a long time.

  4. 1932242bdd892819ef21d87693f149e9?d=mm


    Jan 14, 2018 15:51

    My unity can't find the newest sdk folder, Fix please.

  5. 6ca45dd46b5c60e1f83f900fdb010206?d=mm


    Jan 10, 2018 17:49

    Cbarnes_Bnea, Thank you so much for pointing this. Had already set the path to JDK8, but never thought that just having JDK9 will cause the error! Deleting JDK9 from the JavaVirtualMachines folder solves it!

  6. 2093c89f135a046310d51ea832e34991?d=mm


    Jan 05, 2018 02:53

    Hello, in this video i explain how to resolve this problem

  7. 3cf8443762d6a25963b580ceaffbb0f0?d=mm


    Dec 29, 2017 01:38

    Thank @NOUMANNOOR987
    Its help to sort out my same problem.
    I currently have latest sdk with jdk 8 on unity 2017.3
    and now working .

  8. 58bbee5441c8e58d4211c56e7f204f14?d=mm


    Dec 11, 2017 07:09

    Same problem.
    Please fix.

  9. D110b8d4ab97eb154e59267fd113599d?d=mm


    Dec 11, 2017 06:08

    5.6.3p1 didn't work too

  10. 42488fb398144043ffe8e1f5913eec92?d=mm


    Dec 09, 2017 20:54

    I tried almost all ways that I found here and anothers threads. But, unfortunately, nothing is working. So sad! :(

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.