Search Issue Tracker

Fixed in 2019.3

Fixed in 2018.4, 2019.2



Found in


Issue ID




Adding Cloth component to SkinnedMeshRenderer changes its bounds



Reproduction steps:
1. Open project attached(
2. Open scene (test)
3. Select Rig_Male_Thief_Thug -> Rig_Male_Thief_Thug_Body
4. Add cloth component to it.

Expected result: SkinnedMeshRenderer bounds will stay in its place.
Actual result: SkinnedMeshRenderer bounds changes position.

Fixed in: 2019.3.0a3

Reproduced on: 5.3.7p3, 5.4.4f1, 5.5.1p3, 5.6.0b8.

Comments (27)

  1. A72baba0e25667cea95537b83c8d4d10?d=mm


    Mar 27, 2020 13:04 Yeezy Supply Pandora Yeezy Air Force 1 Nike Air Force 1 Nike Air Max 270 Kobe Bryant Jersey Kobe Bryant Jerseys For Sale Kobe Bryant Jersey 24 Kobe Bryant Website Official Pandora Bijoux Yeezy Yeezy Yeezy Shoes Nike Shoes NFL Jerseys Yeezy Boost 350 Yeezy Yeezy Shoes Yeezy Yeezy Yeezy 350 Yeezy Yeezy Shoes Adidas Yeezy Yeezy 700 Yeezy Boost 350 V2 Nike Outlet Yeezy Shoes MLB Shop Adidas Yeezy MLB Jerseys Yeezy 380 Yeezy 380 Nike Outlet Human Races Human Race Shoes Uggs Official Site Pandora Basketball Jerseys Basketball Jerseys Cheap NBA Jerseys Nike Outlet Pandora Canada Pandora Charms Pandora Jewelry Pandora Outlet Pandora Jewelry Official Site MLB Jerseys Pandora Pandora Bijoux Adidas Yeezy Pandora Soldes 2020 Yeezy Shoes Yeezy Mafia

  2. Adad6bbb0866bf3cc77cf6dfaa91548e?d=mm


    Mar 10, 2020 13:56

    I'm really starting to get mad at Unity. "Fixed in 2018.4, 2019.2, Fixed in 2019.3" my @$$. Every bug that is marked "Fixed" has a 70% chance that it's NOT "fixed" and then they refuse to reopen the issue >:(

    The only one who really helps with the bugs is the community that finds a workaround.
    What does the "S" in "LTS" stand for? "Sham"? Long Term Sham?

    PS : 2020.1.0a22 and still not working. And, no, It doesn't work in the LTS versions(eg 2019.3.4f1) either.

  3. Fb9668f63e0579586d5582f86bccd6b7?d=mm


    Feb 09, 2020 23:26

    I'm seeing this in 2020.1.0a22

  4. Fca5476a343ff11369850590125bbe0c?d=mm


    Feb 08, 2020 16:55

    Heres a possible fix that worked in my case.

    It says to add a empty game object, then add skin mesh renderer component, and finally add the cloth component. This worked for me and fixed the scaling issue. Hope this helps

  5. 3ea8707c3fb662f4672017472f1692cf?d=mm


    Oct 17, 2019 19:00

    None of the proposed fixes are working for me on 2019.2

  6. Da37c8122786e06969aca297cb5c264b?d=mm


    Sep 08, 2019 16:16

    It is fixed in 2018.4.8

  7. 1ef184756ff2918aaeb80a5ae3e61515?d=mm


    Aug 26, 2019 09:40

    What does it mean that this is "By Design" in 2018.4 ? It broke during 2018.4 development...

    So much for LTS being the safest option for us developers...

  8. Da37c8122786e06969aca297cb5c264b?d=mm


    Aug 16, 2019 12:28

    Ok, my previous solution does not work in particular builds. Pretty sure this problem started appearing with 2018.4.3f1 there is also mention in the changelog: Physics Fixed issue with bounds in SkinnedMeshRenderer. (1153167)

  9. Da37c8122786e06969aca297cb5c264b?d=mm


    Aug 15, 2019 18:48

    I had the same issue I couldn't upgrade to 2019.2 due to various other cloth bugs so I just force the skinned mesh renderer bounds in a script. This might help someone.

  10. 1ef184756ff2918aaeb80a5ae3e61515?d=mm


    Aug 07, 2019 07:26

    Not sure if this is the same issue or not, but I still get missing Cloth in 2019.2.0f1 when a Cloth component has "Update When Offscreen" unchecked. I have to toggle it, then toggle it off again to make the Cloth appear.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.