Search Issue Tracker

Fixed in URP master branch

Votes

32

Found in [Package]

12.0.0

Issue ID

1335524

Regression

No

[XR SDK][URP]Game view is rendered grey for left eye and black for right eye when using Single Pass Instanced and Render Feature

Package: Scriptable Render Pipeline Universal

-

Reproduction steps:
1. Open the user's attached project ("_ISSUE_XR_SRF.zip.zip")
2. Load "Scene"
3. Make sure Rendering Mode is set to Single Pass Instanced in XR Plug-in Management provider's settings
4. Enter play mode

Expected result: the Game view is properly rendered for both eyes
Actual result: the Game view is rendered grey for the left eye and black for the right eye

Reproducible with: URP 10.5.0, 11.0.0, 12.0.0 (2020.3.8f1, 2021.1.7f1, 2021.2.0a17)
Could not test with: 2018.4.30f1 (XR SDK not available), 2019.4.27f1 (compilation errros after downgrade)

Notes:
- reproducible with MockHMD and Oculus plug-in loaders
- setting render mode to Multi Pass renders the Game view correctly
- the issue is not reproducible with "Before Rendering Opaques" Render Pass Event

  1. Resolution Note (fix version URP master branch):

    The grey on one eye and black on the other eye is solved by restoring XR SPI keywords. Some keywords are not restored correctly in the case of using cmd,blit.
    See: https://docs.unity3d.com/Packages/com.unity.render-pipelines.universal@13.0/manual/renderer-features/how-to-fullscreen-blit-in-xr-spi.html

Comments (6)

  1. rz_0lento

    Aug 16, 2021 15:08

    It doesn't look like Unity is going to fix the broken Blit for SPI but Unity did work around it on URP SSAO Renderer Feature using DrawMesh instead of Blit.

    I tried to make simpler example of this type of usage here, hope it helps someone:
    https://github.com/0lento/URP_RendererFeature_SPI_Example

    This sample just implements simple saturation effect that still works while using VR + SPI.

  2. wuenscher

    Aug 13, 2021 14:14

    still there with openxr and unity 2020.3.16

  3. blagwedge

    Aug 07, 2021 07:21

    I'm on 2020.3.5 and i'm having this exact problem. Was it ever fixed?

  4. Extrys

    Aug 06, 2021 14:26

    Same issue here, this make me not being able to update unity, because my project heavily depends on this feature

  5. Cecrit

    Jul 15, 2021 06:48

    I'm facing the exect same issue in 2020.3 and 2021.2 as well. I don't see many people talking about it though. let's hope it gets fixed.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.