Search Issue Tracker

Fixed in 1.0.2

Votes

11

Found in [Package]

preview - 0.2.4

Issue ID

1149977

Regression

No

[WebGL] NetworkDiscovery.cs build errors when trying to build a project with Multiplayer HLAPI

Package: Multiplayer hlapi

-

How to reproduce:
1. Open the attached project ('1149977repro.zip')
2. Build for WebGL

Expected results: Project is successfully built
Actual results: Project is unable to be built because of 4 identical NetworkDiscovery.cs errors

Reproducible with: 2019.1.1f1, 2019.2.0a14, 2019.3.0a1
and with all package versions
Multiplayer HLAPI package was introduced in 2019.1.0a12

The build error occurs in 4 different places in Network Discovery.cs:
Library\PackageCache\com.unity.multiplayer-hlapi@1.0.2\Runtime\NetworkDiscovery.cs(317,30): error CS0117: 'NetworkTransport' does not contain a definition for 'SetMulticastLock'
Library\PackageCache\com.unity.multiplayer-hlapi@1.0.2\Runtime\NetworkDiscovery.cs(348,30): error CS0117: 'NetworkTransport' does not contain a definition for 'SetMulticastLock'
Library\PackageCache\com.unity.multiplayer-hlapi@1.0.2\Runtime\NetworkDiscovery.cs(388,30): error CS0117: 'NetworkTransport' does not contain a definition for 'SetMulticastLock'
Library\PackageCache\com.unity.multiplayer-hlapi@1.0.2\Runtime\NetworkDiscovery.cs(449,34): error CS0117: 'NetworkTransport' does not contain a definition for 'SetMulticastLock'

  1. Response avatar

    Resolution Note (fix version 1.0.2):

    Fixed in 2019.3.0a5

Comments (11)

  1. 5a7f827b021e7977bb9ea1fd9549ec73?d=mm

    ryoma-gerald

    Aug 30, 2019 14:58

    @DAJELLOKING Your solution works, thank you!

  2. B482b83ec99d9495ddc16dd05cd29044?d=mm

    ImperativeGames

    Jul 22, 2019 20:59

    RESOLUTION NOTE (FIX VERSION 1.0.2):
    Fixed in 2019.3.0a5

    Are you kidding? What if I don't make projects in superbuggy 2019.3.0a??? Will it be fixed in actual versions?

  3. 2bbfa0ecfd73844b912265682a6e6a27?d=mm

    PurplishCat

    Jun 25, 2019 02:52

    I'm getting this in 2019.1.7f1. Regression? Work-around?

  4. C1e0fe9cee079cfdbeeb49cc009a7075?d=mm

    Blue-Mirror

    Jun 21, 2019 10:43

    @DAJELLOKING Heck yeah!

  5. 7ff9e481d1deffc8fcd1abf3aef43477?d=mm

    coronepan

    Jun 19, 2019 16:56

    DAJELLOKING
    thank you bro !! i owe you one
    come here at Kyoto I will buy you drink ahaahahaha

  6. 005bf585e366831e2d2fec7bf4120206?d=mm

    pginiotis

    May 30, 2019 06:34

    Issue is fixed in 2019.3.0a5

  7. 2fedd246adac47959cbeaeb208156630?d=mm

    Cani23

    May 27, 2019 18:11

    Why is this problem still not solved?

  8. 58c855f254fd685c75d0b1eaa16f06de?d=mm

    helldress

    May 23, 2019 23:04

    DAJELLOKING thank you!

  9. 2fedd246adac47959cbeaeb208156630?d=mm

    Cani23

    May 16, 2019 21:46

    We expect the fix for this error.

  10. 2d0bf1b2e2254a709bb47a34d6c98628?d=mm

    DaJelloKing

    May 09, 2019 04:38

    I fixed this by going to Window> package manager and selecting the Multiplayer hlapi package and clicking remove.

    I did this for a non multiplayer game and it seems to have no issues because of it.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.